Hostapd to Wpa_supplicant 4 way Handshake Problem

Jouni Malinen j at w1.fi
Tue Sep 30 07:16:50 EDT 2008


On Mon, Sep 22, 2008 at 07:42:34AM -0400, Steve Brown wrote:

> The failures are random and appear as a timeout after sending the first 
> handshake 1/4. I enabled timestamps in hostapd and notice that the time 
> between the send and the timeout is very short, only a few hundred 
> microseconds. The call to eloop_register_timeout sets a 1sec timeout. A 
> sniffer confirms the rapid transmit of 2 EAPOL packets, with the second 
> appearing within same short time, even before the receiving station has 
> time to send an ACK.
>
> I have appended hostapd output from both a successful and failing case.

What exactly do you mean with "failing case" here? Just the need to
re-transmit message 1/4 once or failure to actually complete 4-way
handshake?

The debug output you included here shows that message 1/4 is sent at
1222006706.852930 and the timeout is indicated at 1222006707.853203,
i.e., 1.000273 seconds after the transmission. Are you saying that the
sniffer is showing these frames to be next to each other? Please make
sure you do not look at timestamps of possible lower layer
retransmission of the same frame. At least as far as the debug log is
concerned, it seems to show expected behavior and 4-way handshake
process was recovered with the retry (i.e., supplicant responded with
msg 2/4).

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list