Can hostap&madwifi support several bcast keys of one AP?

=?gb2312?q?=CD=F5=ABh?= wangyue0921 at yahoo.com.cn
Thu Oct 9 20:43:45 EDT 2008


Sorry to send private mail, i responsed the last 
letter to private address because of my carelessness.

In the http://wireless.kernel.org/
it says:
You can download compat-wireless for kernels <= 2.6.26
here: 
http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-old.tar.bz2

So when i update the kernel to 2.6.26 and build 
compat-wireless-2.6-old, it should be OK as well?

Thanks for ur letter, I will try the 2.6.27-rc8 and 
wireless-testing now.

--- Pavel Roskin <proski at gnu.org>дµÀ:

> On Thu, 2008-10-09 at 10:02 +0800, ²¦Ë?wrote:
> > > Maybe you checked
> > > out the sources in Windows?
> > 
> > Yes, I did it in windows and this problem was
> exactly
> > caused by it.
> 
> OK, good to know.
> 
> > So i check out source in linux again, and make it.
> > But there are several warnings as:
> > WARNING: "ieee80211_hdrlen"
> >
>
[/home/wangyue/source_bak/compat-wireless-2.6-old/drivers/net/wireless/b43legacy/b43legacy.ko]
> > undefined!
> > WARNING: "ieee80211_hdrlen"
> >
>
[/home/wangyue/source_bak/compat-wireless-2.6-old/drivers/net/wireless/ath5k/ath5k.ko]
> > undefined!
> 
> I don't understand how you could get error messages
> about something
> under compat-wireless-2.6-old while building the
> kernel.
> 
> ieee80211_hdrlen() is defined in
> net/mac80211/util.c.  I don't get that
> error.  That function should be in the kernel if
> CONFIG_MAC80211 is
> defined in .config file.
> 
> > The new module can be built, but when i insmod 
> > ath5k.ko, it says:
> > [root at telnetserver ath5k]# insmod ath5k.ko
> > insmod: error inserting 'ath5k.ko': -1 Unknown
> symbol
> > in module
> > And dmesg says:
> > ath5k: Unknown symbol ieee80211_hdrlen
> 
> I believe you are using some other kernel.  But I
> still don't understand
> the message during the build.  Maybe the sources are
> corrupted or you
> posted error messages from building
> compat-wireless-2.6-old, not the
> kernel.
> 
> > My env is fc7, and i have updated the kernel to
> > 2.6.26.
> 
> The current wireless-testing displays version as
> 2.6.27-rc8.  You must
> be running a wrong kernel.
> 
> > I have tried several packages, and the errors are
> > same.
> 
> I don't know what packages you mean.
> 
> Please don't take the discussion private.  I'm not
> going to answer
> further private messages.
> 
> -- 
> Regards,
> Pavel Roskin
> 



      ___________________________________________________________ 
 ÑÅ»¢ÓÊÏ䣬ÄúµÄÖÕÉúÓÊÏ䣡 
http://cn.mail.yahoo.com/



More information about the HostAP mailing list