Getting SMC2532W-B to work

Joseph Spitz josephgrey at gmail.com
Sat Oct 4 15:23:38 EDT 2008


I have been unable to get my wireless card working.  The card is a PCMCIA
SMC2532W_B card. I am using the hostap_cs module in kernel 2.26-r8. Using
gentoo linux.

When I plug the card into the card slot /var/log/messages says:

Oct 4 14:13:40 sunshine pccard: PCMCIA card inserted into slot 1
Oct 4 14:13:40 sunshine pcmcia: registering new device pcmcia1.0
Oct 4 14:13:40 sunshine hostap_cs: setting Vcc=33 (constant)
Oct 4 14:13:40 sunshine Checking CFTABLE_ENTRY 0x01 (default 0x01)
Oct 4 14:13:40 sunshine IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
Oct 4 14:13:40 sunshine io->flags = 0x0047, io.base=0x0000, len=128
Oct 4 14:13:40 sunshine hostap_cs: Registered netdevice wifi0
Oct 4 14:13:40 sunshine pcmcia: request for exclusive IRQ could not be
fulfilled.
Oct 4 14:13:40 sunshine pcmcia: the driver needs updating to supported
shared IRQ lines.
Oct 4 14:13:40 sunshine hostap_cs: index 0x01: , irq 10, io 0x0200-0x027f
Oct 4 14:13:41 sunshine hostap_cs: assuming no Primary image in flash - card
initialization not completed
Oct 4 14:13:41 sunshine wifi0: test Genesis mode with HCR 0x1f
Oct 4 14:13:41 sunshine prism2_pccard_cor_sreset: original COR 41
Oct 4 14:13:41 sunshine prism2_pccard_genesis_sreset: original COR 41
Oct 4 14:13:41 sunshine Readback test failed, HCR 0x1f write 00 e1 a1 ff
read 00 c1 a1 c1
Oct 4 14:13:41 sunshine wifi0: test Genesis mode with HCR 0x0f
Oct 4 14:13:41 sunshine prism2_pccard_cor_sreset: original COR 41
Oct 4 14:13:41 sunshine prism2_pccard_genesis_sreset: original COR 41
Oct 4 14:13:41 sunshine Readback test succeeded, HCR 0x0f
Oct 4 14:13:41 sunshine prism2_pccard_genesis_sreset: original COR 41
Oct 4 14:13:41 sunshine wifi0: registered netdevice wlan0
Oct 4 14:13:41 sunshine cardmgr[7732]: unsupported card in socket 1
Oct 4 14:13:41 sunshine wifi0: cannot get RID fdc6 (len=12) - no PRI f/w
Oct 4 14:13:41 sunshine wlan0: cannot get RID fdc6 (len=12) - no PRI f/w
Oct 4 14:13:41 sunshine cardmgr[7732]: product info: "SMC", "SMC2532W-B
EliteConnect Wireless Adapter", "", ""
Oct 4 14:13:41 sunshine cardmgr[7732]: manfid: 0xd601, 0x0010 function: 6
(network)
Oct 4 14:13:42 sunshine wifi0: cannot get RID fdc6 (len=12) - no PRI f/w
Oct 4 14:13:42 sunshine wlan0: cannot get RID fdc6 (len=12) - no PRI f/w
Oct 4 14:13:43 sunshine wifi0: cannot get RID fdc6 (len=12) - no PRI f/w
Oct 4 14:13:43 sunshine wlan0: cannot get RID fdc6 (len=12) - no PRI f/w

...and the last two messages repeat over and over again.  It looks like a
firmware problem.

It's not hardware because the card works in windows, and ubuntu linux (on
the same laptop.)  I would like to get it working in Gentoo linux, but I
can't figure out what is going wrong.

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20081004/4ef825c2/attachment.htm 


More information about the HostAP mailing list