hostapd and b43: can do unencrypted, cannot do WPA - continued

Jouni Malinen j at w1.fi
Wed May 7 05:30:06 EDT 2008


On Thu, May 01, 2008 at 06:54:37PM +0200, Francis Galiegue wrote:

> I managed to drop the sigsegv when setting up WPA, however, the WPA
> negotiation completes but... The station is deassociated just
> afterwards due to inactivity (uh, what activity? I didn't even get the
> chance to send anything!):

> wlan0: STA 00:15:00:35:12:e0 WPA: group key handshake completed (WPA)
> WPA: 00:15:00:35:12:e0 WPA_PTK_GROUP entering state IDLE
> MGMT
> mgmt::disassoc
> disassocation: STA=00:15:00:35:12:e0 reason_code=1

This is telling that hostapd received disassociation frame from the
client, i.e., it was the client that requested to be disconnected..

> wlan0: STA 00:15:00:35:12:e0 IEEE 802.11: deauthenticated due to inactivity

There is a short timeout on moving from disassociated state to
deauthenticated in hostapd. In other words, I would expect this to be
just cleanup on the hostapd and that was triggered by the client
deciding to disassociate.

> Related or not, it also happens that, in unencrypted mode, the same
> station also gets disconnected to to inactivity once, twice, before
> the AP lets it, at last, send a DHCP request.
> 
> What could be the problem?

Which client are you using? Can you get debug information from it
related to authentication and association? I would take a look at that
information to figure out why it ends up sending that disassociation
frame.
 
-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list