Rate seems limited to 1M

GNUtoo at no-log.org GNUtoo at no-log.org
Mon Jul 28 17:04:00 EDT 2008


Hello,
I've several clients:
*gentoo
*ubuntu
*windows XP

And all of the 3 kind of clients report rates of 1Mb/s.
(using iwconfig or the icon in widows XP)

I've put my gentoo laptop near the ap and it didn't change the
rate(iwconfig on the laptop still reported 1M)...
So I've ran a file transfer using sftp and artificially put the rate at
54M...near the router it's at more than 1MB/s,and going at the place where
the laptop should be it's more than 500k/s and with the rate at 1M it's
less than 100k...
And I don't know how to solve it because of the windows XP client...i
don't even know if it's possible to set the rate inside windows XP

Here's my setup:
*gentoo
*kernel 2.6.26 vanilla
*patch for allowing the master mode in the 2.6.26 kernel(allow-ap-vlan-modes)
*ralink rt2500 pci with a special antenna
*hostapd from git
*this config:
interface=wlan0
driver=nl80211
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=my_essid_contains_underscores
country_code=IT
hw_mode=g
channel=11
beacon_int=100
dtim_period=2
max_num_sta=255
rts_threshold=2347
fragm_threshold=2346
supported_rates=10 20 55 110 60 90 120 180 240 360 480 540
macaddr_acl=0
auth_algs=3
ignore_broadcast_ssid=0
wme_enabled=1
wme_ac_bk_cwmin=4
wme_ac_bk_cwmax=10
wme_ac_bk_aifs=7
wme_ac_bk_txop_limit=0
wme_ac_bk_acm=0
wme_ac_be_aifs=3
wme_ac_be_cwmin=4
wme_ac_be_cwmax=10
wme_ac_be_txop_limit=0
wme_ac_be_acm=0
wme_ac_vi_aifs=2
wme_ac_vi_cwmin=3
wme_ac_vi_cwmax=4
wme_ac_vi_txop_limit=94
wme_ac_vi_acm=0
wme_ac_vo_aifs=2
wme_ac_vo_cwmin=2
wme_ac_vo_cwmax=3
wme_ac_vo_txop_limit=47
wme_ac_vo_acm=0
eapol_key_index_workaround=0
eap_server=0

i've also tried with this line commented:
supported_rates=10 20 55 110 60 90 120 180 240 360 480 540

Thanks in advance for your help



More information about the HostAP mailing list