WPA-PSK doesn't seem to work.

info at sorcix.com info at sorcix.com
Sun Jul 27 07:00:46 EDT 2008

Hi guys,

This is the first time I'm sending to a mailing list,
so I hope I didn't do something wrong here. ^^

I have a wireless network protected with WPA-PSK, but for some reason
wpa_supplicant seems to be using EAP when connecting (and fails). I'm trying
to fix this for several days now, and have tried lots of different
configurations, but none worked.

Output: http://doc.sorcix.com/public/wpa/wpa_supplicant.txt
Config: http://doc.sorcix.com/public/wpa/demunetap.conf
Router setup: http://doc.sorcix.com/public/wpa/router.jpg

Router: DLink DIR-635
WNIC: DLink DWA-547 (Chipset AR5416) using ndiswrapper


I have tried the same configuration on another router (USR XX5462), including
the same PSK and SSID. It worked perfectly on this one! wpa_supplicant
never even mentioned EAP and connected in a few seconds.


Because wpa_supplicant seems to be using EAP where it shouldn't, I tried to
compile without EAP support, but then wpa_supplicant just said it needed
EAP to connect to my DLink router.


This might be interesting also:
Windows is able to connect to my router, but complains that it needs a
certificate. The connection works as expected though, it just says every 10
minutes that it couldn't find a certificate.

Is there any way to fix this problem, or at least just do it as windows
and ignore the certificate stuff? I have not setup a certificate on the
so I don't understand why I should need one, or even how I should make one.

More information about the HostAP mailing list