problem about WPS proxy function?

leeliu jordanliuster at gmail.com
Sat Jan 26 04:35:28 EST 2008


Hi All,

I test WPS function using the following settings
(see http://www.intel.com/cd/ids/developer/asmo-na/eng/247741.htm):

1)Registrar:
S/W: Windows Vista

2)AP/Proxy:
H/W: atheros AR5212 wireless card
S/W: Linux FedoraCore4, madwifi-ng-r1497(orig), hostapd-0.4.8(add
intel's patch), WscRefImpl_Intel_1_0_6(from intel)

3)Client:
H/W: atheros AR5212 wireless card
S/W: Linux FedoraCore4, madwifi-ng-r1497(orig),
wpa_supplicant-0.4.8(add intel's patch), WscRefImpl_Intel_1_0_6(from
intel)

I can't test it sucessfully when AP acts as Proxy function, but most
of other functions is ok. Below is my hostapd.conf when run wsccmd in
AP:
=================================================
interface=ath0

logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2

# Debugging: 0 = no, 1 = minimal, 2 = verbose, 3 = msg dumps, 4 = excessive
debug=2

# Dump file for state information (on SIGUSR1)
dump_file=/tmp/hostapd.dump

ctrl_interface=/var/run/hostapd
ctrl_interface_group=0

# 802.11
macaddr_acl=0
auth_algs=3

# 802.1x
ieee8021x=1
eap_server=1
eap_user_file=hostapd.eap_user
eap_message=hello
eapol_key_index_workaround=0

# radius serverWscSecureAP
own_ip_addr=127.0.0.1

# WPA/IEEE802.11i
wpa=3
wpa_pairwise=TKIP CCMP
ssid=WscSecureAP
wpa_key_mgmt=WPA-PSK
wpa_psk=4bd48a499c7e7deabc86002a4289aa9ce80ea80e016f97b0d7bdba7f3a17cf03
==================================================

And the error message when talk through EAP is:
---------------------------------------------------
...
ath0: STA 00:40:f4:82:ld:dc IEEE 802.11: associated
  New STA
ioctl[unknown???]: Invalid argument
Failed to get WPA/RSN information element.
Data frame from not associated STA 00:40:f4:82:ld:dc
Wireless event: cmd=0x8c04 len=20
ath0: STA 00:40:f4:82:ld:dc IEEE 802.11: deassociated
ath0: STA 00:40:f4:82:ld:dc WPA: event 2 notification
Wireless event: cmd=0x8c03 len=20
ath0: STA 00:40:f4:82:ld:dc IEEE 802.11: associated
  New STA
...
---------------------------------------------------

Is that my driver's problem or other errors?

Thanks.

-- 
Best Regards,

Lorin


More information about the HostAP mailing list