ndis_events.c and WMI failures

Ridouan Agarad ridouan at gmail.com
Wed Feb 13 10:22:44 EST 2008


Hi All,

While testing wpa_supplicant (version 0.5.9) on Windows 2000, I got problems
getting the supplicant to run correctly. It kept failing, complaining about
WMI errors.
I've searched the mailing list, but found only 1 reference to approx. the
same issue, but no solution.

So, I've been doing some debugging and it seems that when COM needs to do
marshaling, the failures occurred. Further looking showed that some function
calls
(such as IWbemServices_ExecQuery) passed L"" strings, while BSTR's needed to
passed. Making a wrapper to convert WCHARs to BSTRs solved the problem and
the supplicant is now working OK on Windows 2000.

Potentially, the same situation could also occur on Windows XP, but for some
reason marshaling was not triggered while performing my tests on XP.

This being my first interaction with the list and having no idea about the
regular way to post modified files, I've simply attached the diff for the
ndis_events.c (from 0.5.9) file for you guys to have a look at. It seems
that the 0.6.2 binaries suffers from the same issue, but I haven't looked at
ndis_events.c from 0.6.2 yet

Kind regards,
Ridouan Agarad.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20080213/10359b04/attachment.htm 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ndis_events.c.diff
Url: http://lists.shmoo.com/pipermail/hostap/attachments/20080213/10359b04/attachment.txt 


More information about the HostAP mailing list