Segmentation Fault when using external RADIUS server

Ray Overland roverland at microhardcorp.com
Fri Feb 1 13:51:13 EST 2008


tyvm

Jouni Malinen wrote:
> On Thu, Jan 31, 2008 at 08:33:56AM -0700, Ray Overland wrote:
> 
>> I am hoping someone can help me with the problem I am seeing. I am getting a seg fault 
>> when I have an xscale based AP set up running hostapd-0.6.2. I have freeradius 1.1.4 
>> running on FC6, and I know that it works with hostapd-0.5.9, however I have to use 0.6.2, 
>> so I need to fix this problem, one way or another.
>>
>> I noticed that I would infrequently get a seg fault when the server was available to the 
>> AP, but then I disconnected the freeradius server, and the seg fault shows up every time, 
>> very reproducible.
> 
> Thanks for reporting this. I found the bug and it is now fixed in the
> Git repository. You should be able to fix 0.6.2 version with the same
> change (attached).
> 
> 
> 
> ------------------------------------------------------------------------
> 
> diff --git a/hostapd/eapol_sm.c b/hostapd/eapol_sm.c
> index 1b277d6..2e63bef 100644
> --- a/hostapd/eapol_sm.c
> +++ b/hostapd/eapol_sm.c
> @@ -901,6 +901,11 @@ restart:
>  		/* TODO: find a better location for this */
>  		if (sm->eap_if->aaaEapResp) {
>  			sm->eap_if->aaaEapResp = FALSE;
> +			if (sm->eap_if->aaaEapRespData == NULL) {
> +				wpa_printf(MSG_DEBUG, "EAPOL: aaaEapResp set, "
> +					   "but no aaaEapRespData available");
> +				return;
> +			}
>  			sm->eapol->cb.aaa_send(
>  				sm->hapd, sm->sta,
>  				wpabuf_head(sm->eap_if->aaaEapRespData),
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

-- 
Ray Overland BSc. EE
Senior Software Engineer
Microhard Systems Inc.
http://www.microhardcorp.com
Phone: (403)248-0028 ext 230
Email: roverland at microhardcorp.com


More information about the HostAP mailing list