[patch] NEED_BASE64 for WPS

Andriy Tkachuk andriy.tkachuk at inobject.com
Fri Dec 26 10:22:18 EST 2008


It seems that for supplicant it worked because of following section in 
Makefile:

ifeq ($(CONFIG_BACKEND), file)
OBJS += config_file.o
ifndef CONFIG_NO_CONFIG_BLOBS
NEED_BASE64=y
endif
CFLAGS += -DCONFIG_BACKEND_FILE
endif


On 2008-12-26 16:41, Jouni Malinen wrote:
> On Fri, Dec 26, 2008 at 11:30:35AM +0200, Andriy Tkachuk wrote:
>
>   
>> It looks like we need base64 routines when compiling WPS in hostapd
>> (used in src/wps/wps_registrar.c:910). Attached patch helps.
>>     
>
> Thanks! Applied (and also for wpa_supplicant).
>   


More information about the HostAP mailing list