Cannot ping across bridge with hostap

蔡立三 cailisan1985 at gmail.com
Thu Dec 25 06:23:07 EST 2008


Hello
I have met a problem.
The situation is that, I port bridge-utils and hostap-driver to a Embedded
linux system.
It works well.
And I implement the blow command.

./brctl addbr br0
./brctl stp br0 off
./brctl addif br0 eth0
./brctl addif br0 wlan0
ifconfig eth0 down
ifconfig wlan0 down
ifconfig eth0 0.0.0.0 up
ifconfig wlan0 0.0.0.0 up
ifconfig br0 192.168.1.3 netmask 255.255.255.0
 echo "1" > /proc/sys/net/ipv4/ip_forward
cat /proc/sys/net/ipv4/ip_forward
route add default gw 192.168.1.1
route

The command execute correctly.
But I cannot ping through it.
I can just ping from the wireless terminal to br0 and ping from the wired
terminal to br0.
The wireless terminal cannot ping to wired terminal through br0.
the version of linux system is 2.6.8.1 and the version of hostap-driver is
0.1.3.
The situation like below:

                     router 192.168.1.1
                                |
                                |
                          wired
                     ap (embeded linux with bridge-utils and hostap)
192.168.1.3
                          wireless
                                |
                                |
                     wireless terminal 192.168.1.4

When I do it in the pc with fedora linux, the ap works well.
That surprises me a lot.
So can anybody give me some advice?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20081225/3a250eeb/attachment.htm 


More information about the HostAP mailing list