rt2x00 driver

Iwo Mergler iwo at call-direct.com.au
Wed Dec 10 17:41:59 EST 2008


Gábor Molnár wrote:
> Hi!
> 
> I have a rt73-baseb usb dongle, and i want to use it in master mode,
> so i downloaded and compiled the latest rt2x00 kernel source from git,
> and compiled it succesfully. HostAPd seems to work correctly at first
> sight, sends out beacons, and the client can associate as well. But
> when the client is associated, the hostapd log says, that "wlan1: STA
> 00:14:a5:29:e0:98 IEEE 802.11: did not acknowledge association
> response", and after that, when the client tries to send packages, the
> hostapd forces it to reassociate.
> 
> The hostapd part of the story
> There was a thread earlier in connection with this problem:
> http://readlist.com/lists/shmoo.com/hostap/1/5106.html. The case is
> that the driver doesnt ackowledge the association response.
> 
> The rt2x00 part of the story
> I found a thread in the rt2x00 mailing list, in connection with this:
> http://sourceforge.net/mailarchive/message.php?msg_id=200808082059.11968.IvDoorn%40gmail.com
> (the discussion is about 3 different patch, the first one is the
> important part, but in the end, the patch wasn't accepted) and another
> thread in their forums:
> http://rt2x00.serialmonkey.com/phpBB/viewtopic.php?f=5&t=4790&p=30366
> . They say, that "there is simply no way to tell if the frame was
> successfully send or not". So, the driver cannot acknowledge this, and
> they say, that handling this situation is the responsibility of
> hostapd.
> 
> Now everybody says that this is the responsibility of the other one.
> Now you can see the situation clear. What do you think about this
> issue?
> 

Hi Gábor,

As far as I can tell, everyone is right.



More information about the HostAP mailing list