Compiling hostapd from git with libnl also from git...

john dowd jdowdster at gmail.com
Tue Dec 9 11:36:22 EST 2008


Jouni,

(There was a loud smack sound in my office as I hit my forehead with my hand!!)

Thanks for your reply. I was just checking and your are correct, I
fixed my makefile since I had changed it to link to the libnl-genl
libary. I've removed all of my changes I did to fix the various symbol
resolution errors I was getting. I'm now just using the hostapd 0.6.6
and the libnl delivered with my distro. It compiles fine and runs.
Unfortunately I'm having the same problems with my access point. It is
not being advertised and the debug out that I've listed on this site
shows that the TX callback is failing:

1228840205.186928: handle_tx_callback(): MGMT (TX callback) fail
1228840205.186954: mgmt::proberesp cb

I modified the debug to include the name of the function where the
failure was being reported.

Cheers!!

On Tue, Dec 9, 2008 at 11:29 AM, Jouni Malinen <j at w1.fi> wrote:
> On Tue, Dec 09, 2008 at 11:19:58AM -0500, john dowd wrote:
>
>> Perhaps there's something I don't understand about the release
>> numbers. The library
>> libnl 1.1-21 appears to be the latest released to my distro opensuse
>> 11.0. (It's what I see when I go into the "yast" s/w install tool and
>> check the version). I get the following errors when I link using it:
>>
>> /usr/lib/libnl-genl.so: undefined reference to `__flags2str'
>> /usr/lib/libnl-genl.so: undefined reference to `nl_dump_line'
>> /usr/lib/libnl-genl.so: undefined reference to `nl_cache_alloc_and_fill'
>> collect2: ld returned 1 exit status
>> make: *** [hostapd] Error 1
>
> How did you end up trying to link in libnl-genl.so with libnl 1.1?
> hostapd Makefile should only link in libnl.so with that version.
>
>> Can I use the git API to download the libnl version that I require?
>
> That would be a question to libnl maintainer. Do you have a requirement
> of using git for this? Would not just using the latest stable release
> file (http://people.suug.ch/~tgr/libnl/files/libnl-1.1.tar.gz) be
> easier?
>
>> It's very frustrating to trace this stuff since if you do a "google"
>> search on using master mode for my particular h/w I get a lot of
>> information that until you really look into it, is in some cases 3
>> years old and is therefore obsolete. I understood that I required the
>> latest kernel being used by the wireless development team which is the
>> 2.6.28-rc5 kernel. I then needed the latest hostapd 0.6.6 and the
>> latest libnl from git.
>
> At this point, the latest git snapshot comment is probably good for the
> kernel and hostapd. However, it is not valid for libnl anymore. libnl
> 1.1 seems to work fine and it is included in many recent distributions
> (e.g., I did not need to do anything specific to build hostapd on Ubuntu
> 8.10).
>
>> Can you perhaps lend some clarity to my situation. If you can perhaps
>> just tell me which hostapd and libnl library versions that I require
>> it would be really helpful.
>
> I would use hostapd from git and libnl from the URL I mentioned above.
> If you have a requirement (the reason for which I do not understand) of
> using libnl git snapshot, you may be able to do that by adding
> CONFIG_LIBNL20=y into hostapd .config.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>



-- 
                              John Dowd
                              jdowd at slashdevslashnull.org
                              133 Waverley St.
                              Ottawa Ont. K2P 0V3
                              Home: (613)234-7884
                              Cell: (613)316-7884


More information about the HostAP mailing list