Problem with acx111

Jouni Malinen j at
Thu Apr 3 12:25:07 EDT 2008

On Mon, Mar 31, 2008 at 10:47:37PM +0200, Henning Moll wrote:
> > 	if (key_info & WPA_KEY_INFO_INSTALL) {
> > 		os_sleep(0, 500000); /* add this line here */
> > 		wpa_supplicant_install_ptk(sm, key);

> Good news: That modification solved the problem! I tried it many times 
> with and without load. No problems so far. I am very happy with this as 
> a workaround, but maybe it should be applied in some way?

Well, this is just a workaround, not a real solution, but anyway, this
confirms that the issue is most likely in the race condition between
configuring the pairwise key and sending a packet that would use this
key. I don't like the idea of just adding a random delay here since this
would slow down handshake for everyone while this is not really needed
with most drivers.

I haven't found a suitable WLAN card/driver that would show this type of
behavior, so I do not have a test setup for experimenting with
timing/order changes. I don't know whether ndiswrapper has anything to
do with this race or whether this is just the NDIS driver managing to
configure keys very quickly and/or somehow delay the sending of the next
frame when a key change is in progress. In most cases, I would prefer to
use time on testing and improving open source drivers, if available,
instead of using ndiswrapper, so this is of somewhat limited interest
for me.

Since you mentioned that the card works fine in Windows, I would be
interested in knowing whether it works with wpa_supplicant under Windows
since that could provide more information to figure out whether this
issue is related to ndiswrapper or not.

Which card (vendor/model) are you using? Do you know whether it is
easily available for purchase somewhere in EU?

Jouni Malinen                                            PGP id EFC895FA

More information about the HostAP mailing list