Marvell 8686 with wpa-supplicant problem ...

ScottLiu scott_liu at amit.com.tw
Wed Oct 31 22:33:36 EDT 2007


 

Hi folks,

 

I'm new to the wpa_supplicant. I tried to run wpa_supplicant 0.6.0 (openssl
9.8e) with Marvell8686 SDIO wifi chip, but fail.

I know Marvell8686 works on Linux Kernel 2.6 above but I porting it to 2.4
Kenrel for some specific needs.

Most function is just fine unless with wpa_supplicant, below is error logs,

 

# ./wpa_supplicant -c/etc/wpa_supplicant.conf  -iwl0

ioctl[SIOCSIWPMKSA]: Invalid argument

Enter wlan_setwpaie_ioctl

failed to copy WPA IE

ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad addressEnter wlan_setwpaie_ioctl

 

failed to copy WPA IE

ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad address

ioctl[PRISM2_IOCTL_HOSTAPD]: IEnter wlan_setwpaie_ioctl

nvalid argument

Failed to set encryption.

ioctl[PRISM2_IOCTL_Hret = 0

OSTAPD]: Invalid argument

Failed to set encryption.

ioctl[PRISEnter wlan_setwpaie_ioctl

M2_IOCTL_HOSTAPD]: Invalid argument

Failed to set encryption.

failed to copy WPA IE

ioctl[PRISM2_IOCTL_HOSTAPD]: Invalid argument

Failed to set encryption.

ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad address

Trying to associate with 00:50:18:21:b4:f5 (SSID='Repeat_Scott' Enter
wlan_setwpaie_ioctl

freq=2437 MHz)

failed to copy WPA IE

ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad addressEnter wlan_setwpaie_ioctl

 

failed to copy WPA IE

ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad addressEnter wlan_setwpaie_ioctl

 

failed to copy WPA IE

ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad address

ioctl[PRISM2_IOCTL_HOSTAPD]: Invalid argument

ioctl[SIOCSIWFREQ]: Operation not supported

ioctl[SIOCSIWESSID]: Connection refused

ioctl[SIOCSIWAP]: Network is unrEnter wlan_setwpaie_ioctl

eachable

ret = 0

Association request to the driver failed

CTRL-EVENT-TERMINATING - signal 2 received

ioctl[PRISM2_IOCTL_HOSTAPD]: InvEnter wlan_setwpaie_ioctl

alid argument

ret = 0

Enter wlan_setwpaie_ioctl

ret = 0

Enter wlan_setwpaie_ioctl

ret = 0

Enter wlan_setwpaie_ioctl

ret = 0

ioctl[SIOCSIWAP]: Network is unreachable

 

Please help me on this, any suggestion would be appreciation.

 

Scott

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20071101/90c5af4f/attachment.htm 


More information about the HostAP mailing list