WPA - AP association Issue

Mr. Maloomnahi maloomnahi at indiatimes.com
Tue Oct 30 00:09:50 EDT 2007


Hi Bryan,

Thanks for the valueable inputs again. This is getting productive to understand the working of hostapd / WPA.

1] As far as using the iw* commands are concerned, I do not use them as such If I am running the WPA Src Code. 
2] If I do not set the SSID, it auto scans the network (asap after ifconfig cmd) and associates to another AP in the network which does not have security / authentication activated
3] So I have to use "iwconfig ath0 essid "SEMCO_AP" command and then perform the ifconfig ath0 XX.XX.XX.XX up
4] iwconfig ath0 key XXXX open was performed to see if the settings of WEP key and auth algorithm via command helps the device to associate perfectly
5] It was found that only when we perform this, the device scans the correct AP and associates to the device atleast for 1 minute.
6] On checking the Makefile I found that the CONFIG_BACKEND is set to "file" 

A] Now the OBJS in the Makefile states only config.o and no "config_file.o". I guess I would have to add the object file config_file.o to the list to directly take the CONF file I specify and create the required OBJ file?
B] Shouldnt the command I specify along with " wpa_supplicant -c XXX.conf " automatically take the CONF file for reading and compilation?

Thanks again
PPN

--
My life has changed. What about yours?
Log on to the new Indiatimes Mail and Live out of the Inbox!


More information about the HostAP mailing list