WPA_Supplicant not scanning the AP

maloomnahi at indiatimes.com maloomnahi at indiatimes.com
Fri Oct 5 00:50:29 EDT 2007


Hi,

To start with my system incldues a Linux kernel v2.6.18 Fedora 6, MadWiFi v0.9.3.1, Hostapd v0.5.8, WPA Supplicant v0.5.8 on AR5212 TPLINK card. I am trying to test association using WPA-PSK between an STA and AP. WPA Conf file settings are as follows:

network={
        ssid="AP"
        scan_ssid=1
        psk="secret"
        key_mgmt=WPA-PSK
        priority=2
        auth_alg=OPEN
        mode=0
        wep_tx_keyid0="secret"
        identity="ap"
        anonymous_identity="ap"
        password="secret"
        eappsk="secret"
}

I have one card (computer A) where hostapd AP is running and another card (computer B) where WPA STA is running. Now the problem is that when I perform iwlist scan for the access point the STA is finding the AP in the wireless medium, but when I run the WPA Supplicant command it does not find the AP and does not associate. Following is the dump after testing:

[root at localhost ~]# iwlist ath2 accesspoints

ath2      Peers/Access-Points in range:
    00:14:78:8F:5E:49 : Quality=44/94  Signal level=-51 dBm  Noise level=-95 dBm

[root at localhost ~]# wpa_supplicant -iath2 -Dmadwifi -c wpa_supplicant.conf -ddd

Initializing interface 'ath2' conf '/home/prashant/authenticator/wpa_supplicant-0.5.8/wpa_supplicant.conf' driver 'madwifi' ctrl_interface 'N/A' bridge 'N/A'
Initializing interface (2) 'ath2'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=20 WE(source)=13 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:14:78:8f:73:1f
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_set_countermeasures: enabled=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface ath2
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath2' added
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath2' added
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath2' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 331 bytes of scan results (1 BSSes)
Scan results: 1
No suitable AP found.
Setting scan request: 0 sec 0 usec
No enabled networks - do not scan
State: SCANNING -> INACTIVE
============================
After CTRL+C on the blank screen
============================
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface ath2
State: INACTIVE -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=0
wpa_driver_madwifi_set_countermeasures: enabled=0
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
WEXT: Operstate: linkmode=0, operstate=6

Please help me solve this. Thanks in advance
PPN

--
My life has changed. What about yours?
Log on to the new Indiatimes Mail and Live out of the Inbox!


More information about the HostAP mailing list