Problem connecting to static WEP

Jouni Malinen j at w1.fi
Sun Nov 18 13:43:47 EST 2007


On Sun, Nov 18, 2007 at 12:28:56PM -0600, Laia Manrique wrote:

> I am trying to connect to a static WEP network. When I run wpa_supplicant,
> everything seems to work fine, but I do not get an IP address (dhdcpd times
> out). I have no problems connecting to more spohisticated WPA2 networks. I
> am almost sure that I am doing something stupid, but I have not had much
> luck finding a solution.

> The output of "wpa_supplicant -iwlan0 -Dwext -dd -c/wpa/conf/file" is (by
> the way, I am using ndiswrapper, but -Dndiswrapper does not work):

Which NDIS driver are you using? Have you tried configuring the WEP key
with iwconfig (i.e., without running wpa_supplicant)?

> I have also noticed that the output from wpa_supplicant -dd is the same if I
> put the wrong wep_key0 in the config file...

Static WEP networks do not normally have any way of knowing whether the
key was correct or not during association unless the network is
configured to use shared key authentication. In other words, this is
expected behavior with WEP.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list