wpa_supplicant using EAP-TTLS problem

王奕元 dadai.cm91 at gmail.com
Tue Nov 6 22:01:21 EST 2007


Hello.

I meet a problem about EAP-TTLS authentication.
My wireless card is DWL-G650, using Atheros chipset.
Following is my wpa_supplicant conf:

network={
    ssid="MyAP"
    scan_ssid=1
    key_mgmt=WPA-EAP
    eap=TTLS
    identity="testuser"
    password="testpassword"
    ca_cert="/etc/cert/ca.pem"
    phase2="auth=MD5"
}

on my RADIUS server,
I set following in user file:
DEFAULT Auth-Type = System
        Fall-Through = 1
"testuser"    Cleartext-Password := "testpassword"

After I implement: ./wpa_supplicant -i ath0 -c eap-ttls.conf
the screen shows:

CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with 00:19:5b:ec:9a:70
CTRL-EVENT-EAP-STARTED EAP authentication started
CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
OpenSSL: tls_connection_ca_cert - Failed to load root certificates
error:02001002:system library:fopen:No such file or directory
OpenSSL: pending error: error:2006D080:BIO routines:BIO_new_file:no such
file
OpenSSL: pending error: error:0B084002: x509 certificate
routines:X509_load_cert_crl_file:system lib
OpenSSL: tls_load_ca_der - Failed load CA in DER format
error:02001002:system library:fopen:No such file of directory
OpenSSL: pending error: error:20074002:BIO routines:FILE_CTRL:system lib
OpenSSL: pending error: error:0B06F002:x509 certificate
routines:X509_load_cert_file:system lib
TLS: Failed to set TLS connection parameters
EAP-TTLS: Failed to initialize SSL.

Are there something lack in my computer?
Or my conf setting have something missed?

Thanks for youring answering.
Regard.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20071107/94e0c787/attachment.htm 


More information about the HostAP mailing list