Still can't get this to work at all

Dan Williams dcbw at redhat.com
Mon Nov 5 10:09:24 EST 2007


On Mon, 2007-11-05 at 03:55 -0800, Christopher Bohan wrote:
> I have been trying since June to get wireless networking to work via
> wpa_supplicant without any success. My last requests for help received
> no response. I really need to get this to work, so I have decided to
> ask again.
> 
> I am using a 2.6.23 kernel with the zd1211rw driver built in, and
> wpa_supplicant-0.5.7. I need to connect to a wpa-psk (only) network.
> 
> # dog /etc/wpa_supplicant/wpa_supplicant.conf
> ap_scan=1 
> ctrl_interface=/var/run/wpa_supplicant 
> ctrl_interface_group=0 
> eapol_version=2 
> 
> network={ 
>         bssid=00:11:22:33:44:55 
>         proto=WPA 
>         key_mgmt=WPA-PSK 
>         group=TKIP 
>         pairwise=TKIP 
>        
> psk=0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef 
>         scan_ssid=1 
>         }
> 
> 
> # wpa_supplicant -Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf -dd
> -ieth1
> Initializing interface 'eth1' conf
> '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface
> 'N/A' bridge 'N/A' 
> Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' ->
> '/etc/wpa_supplicant/wpa_supplicant.conf' 
> Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' 
> ap_scan=1 
> ctrl_interface='/var/run/wpa_supplicant' 
> ctrl_interface_group='0' (DEPRECATED) 
> eapol_version=2 
> Line: 6 - start of a new network block 
> BSSID - hexdump(len=6): 00 11 22 33 44 55 
> proto: 0x1 
> key_mgmt: 0x2 
> group: 0x8 
> pairwise: 0x8 
> PSK - hexdump(len=32): [REMOVED] 
> scan_ssid=1 (0x1) 
> Priority group 0 
>    id=0 ssid='' 
> Initializing interface (2) 'eth1' 
> EAPOL: SUPP_PAE entering state DISCONNECTED 
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE 
> EAPOL: SUPP_BE entering state INITIALIZE 
> EAP: EAP entering state DISABLED 
> EAPOL: External notification - portEnabled=0 
> EAPOL: External notification - portValid=0 
> SIOCGIWRANGE: WE(compiled)=22 WE(source)=20 enc_capa=0xf 
>   capabilities: key_mgmt 0xf enc 0xf 
> WEXT: Operstate: linkmode=1, operstate=5 
> Own MAC address: 66:77:88:99:aa:bb 
> wpa_driver_wext_set_wpa 
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0 
> wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0 
> wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0 
> wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0 
> wpa_driver_wext_set_countermeasures 
> wpa_driver_wext_set_drop_unencrypted 
> Setting scan request: 0 sec 100000 usec 
> ctrl_interface_group=0 
> Added interface eth1 
> RTM_NEWLINK: operstate=0 ifi_flags=0x1002 () 
> Wireless event: cmd=0x8b06 len=8 
> RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP]) 
> RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added 
> State: DISCONNECTED -> SCANNING 
> Starting AP scan (specific SSID) 
> Scan SSID - hexdump_ascii(len=0): [NULL] 
> Trying to get current scan results first without requesting a new scan
> to speed up initial association 
> Received 259 bytes of scan results (1 BSSes) 
> Scan results: 1 
> Selecting BSS from priority group 0 
> 0: 00:11:22:33:44:55 ssid='<hidden>' wpa_ie_len=26 rsn_ie_len=0
> caps=0x11 
>    skip - SSID mismatch 
> No suitable AP found. 
> Setting scan request: 0 sec 0 usec 
> Starting AP scan (broadcast SSID) 
> RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP]) 
> Wireless event: cmd=0x8b19 len=8 
> Received 257 bytes of scan results (1 BSSes) 
> Scan results: 1 
> Selecting BSS from priority group 0 
> 0: 00:11:22:33:44:55 ssid='<hidden>' wpa_ie_len=26 rsn_ie_len=0
> caps=0x11 
>    skip - SSID mismatch 
> No suitable AP found. 
> Setting scan request: 5 sec 0 usec 
> 
> [this next block just repeats over and over again until I kill it] 
> 
> Starting AP scan (specific SSID) 
> Scan SSID - hexdump_ascii(len=0): [NULL] 
> RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP]) 
> Wireless event: cmd=0x8b19 len=8 
> Received 257 bytes of scan results (1 BSSes) 
> Scan results: 1 
> Selecting BSS from priority group 0 
> 0: 00:11:22:33:44:55 ssid='<hidden>' wpa_ie_len=26 rsn_ie_len=0
> caps=0x11 
>    skip - SSID mismatch 
> No suitable AP found. 
> Setting scan request: 5 sec 0 usec 
> 
> CTRL-EVENT-TERMINATING - signal 2 received 
> Removing interface eth1 
> State: SCANNING -> DISCONNECTED 
> wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT) 
> WEXT: Operstate: linkmode=-1, operstate=5 
> No keys have been configured - skip key clearing 
> EAPOL: External notification - portEnabled=0 
> EAPOL: External notification - portValid=0 
> wpa_driver_wext_set_wpa 
> wpa_driver_wext_set_drop_unencrypted 
> wpa_driver_wext_set_countermeasures 
> No keys have been configured - skip key clearing 
> Cancelling scan request 
> Cancelling authentication timeout 
> WEXT: Operstate: linkmode=0, operstate=6
> 
> Can anyone tell my why this doesn't work, and what I have to do to get
> it to work?

Specify and SSID in the config file, use ap_scan=2 with the SSID, or
stop hiding the SSID of the AP.

Dan





More information about the HostAP mailing list