Does wpa_supplicant 0.4.9 support WE-21 with driver wext?

Robert Allerstorfer linux-ra at anet.at
Thu Mar 29 07:52:43 EDT 2007


Hi,

I am running Fedora 6 (ppc) on my iBook, which has an internal AirPort
Extreme wireless module, controlled by the Broadcom BCM4306 802.11b/g
chipset. The bcm43xx-firmware files have been provided by extracting
from 'AppleAirPort2' 3.90.34.0.p18 (405.1) and the bcm43xx driver from
the 2.6.20-1.2933.fc6 kernel is loaded, as output from
'/var/log/messages' shows:

Mar 29 09:35:59 fedora-ibook kernel: bcm43xx: PHY connected
Mar 29 09:36:00 fedora-ibook kernel: bcm43xx: Microcode rev 0x122, pl 0x9a (2005-08-15  18:44:03)
Mar 29 09:36:00 fedora-ibook kernel: bcm43xx: Radio turned on
Mar 29 09:36:00 fedora-ibook kernel: bcm43xx: Chip initialized
Mar 29 09:36:00 fedora-ibook kernel: bcm43xx: 30-bit DMA initialized
Mar 29 09:36:00 fedora-ibook kernel: bcm43xx: Keys cleared
Mar 29 09:36:00 fedora-ibook kernel: bcm43xx: Selected 802.11 core (phytype 2)

However, running
wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -ieth1 -Dwext -d
results in

Trying to associate with 00:11:22:33:44:55 (SSID='myaccesspoint' freq=0 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
Overriding auth_alg selection: 0x1
RSN: using IEEE 802.11i/D9.0
WPA: Selected cipher suites: group 16 pairwise 16 key_mgmt 2
WPA: clearing AP WPA IE
WPA: set AP RSN IE - hexdump(len=22): 30 14 01 00 00 0f ac 04 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
WPA: using GTK CCMP
WPA: using PTK CCMP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 04 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
No keys have been configured - skip key clearing
wpa_driver_wext_set_drop_unencrypted
State: SCANNING -> ASSOCIATING
wpa_driver_wext_associate
Setting authentication timeout: 15 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
RSN: Ignored PMKID candidate without preauth flag
Wireless event: cmd=0x8b06 len=8
Wireless event: cmd=0x8b1a len=14
Wireless event: cmd=0x8c02 len=21
Custom wireless event: 'authenticated'
Wireless event: cmd=0x8c02 len=26
Custom wireless event: 'associating failed'

The '/etc/wpa_supplicant/wpa_supplicant.conf' content is:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1

network={
        ssid="any"
        key_mgmt=NONE
}

network={
        priority=100
        scan_ssid=1
        proto=WPA2
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        ssid="myaccesspoint"
        psk="my pass phrase"
}

The 2.6.20 kernel has the WE-21 compiled in, as iwlist shows:
[root at fedora-ibook ~]# iwlist --version
iwlist    Wireless-Tools version 28
          Compatible with Wireless Extension v11 to v20.

Kernel    Currently compiled with Wireless Extension v21.

eth1      Recommend Wireless Extension v18 or later,
          Currently compiled with Wireless Extension v21.

[root at fedora-ibook ~]# iwlist eth1 scan
eth1      Scan completed :
(...)
          Cell 02 - Address: 00:11:22:33:44:55
                    ESSID:"myaccesspoint"
                    Protocol:IEEE 802.11g
                    Mode:Master
                    Channel:10
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=100/100  Signal level=-30 dBm  Noise level=-69 dBm
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP 
                        Pairwise Ciphers (1) : CCMP 
                        Authentication Suites (1) : PSK  
                    Extra: Last beacon: 124ms ago

dmesg contains tons of these error messages:
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: generic IE set to 30140100000fac040100000fac040100000fac020000
SoftMAC: sent association request!
SoftMAC: associating failed (reason: 0x19)!

I read somewhere[1] that there "is a wpa_supplicant WE-21
incompatibility problem". So, my question is, is wpa_supplicant 0.4.9
known to fully support the Wireless Extension v21 using this external
bcm43xx driver? What would be the solution? Upgrading wpa_supplicant
to 0.4.10 or better 0.5.7? Downgrading the kernel to 2.6.18 FC6
originally came with? Giving up?

Thanks!
best regards,
rob.

[1] http://www.ussg.iu.edu/hypermail/linux/kernel/0610.2/2526.html

--




More information about the HostAP mailing list