which branch 4.10 or 5.7 is good for madwifi 0.9.3

Jouni Malinen j at w1.fi
Sun Mar 25 23:39:06 EDT 2007


On Sat, Mar 24, 2007 at 03:30:31PM -0700, Jouni Malinen wrote:
> On Fri, Mar 23, 2007 at 12:22:20PM -0700, hong zhang wrote:
> >   Which branch, 4.10 or 5.7, is good match for version 0.9.3 Madwifi that was released 3/19/2007?  My madwifi driver is upgraded to 0.9.3. But 4.9 wpa_supplicant and hostapd cannot match it.

> Both 0.4.10 and 0.5.7 are expected to work. If not, please send a report
> with more detais.

It looks like 0.4.10 does not actually have all the updates needed for
new madwifi-ng versions as far as hostapd is concerned. I merged in more
changes into 0.4.x branch and uploaded a snapshot version to
http://w1.fi/releases/snapshots/hostapd-0.4-2007-03-25.tar.gz

I verified that hostapd and wpa_supplicant from the current snapshots of
both the 0.4.x and 0.5.x branches work with madwifi 0.9.3. In addition,
I think that 0.4.10 and 0.5.7 were enough for wpa_supplicant to work,
but hostapd will need additional changes which will be included in
0.4.11 (0.5.7 has those, so it is only hostapd 0.4.10 that does not work
with madwifi 0.9.3 for some configurations).

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list