driver_broadcom.c problem?

Jouni Malinen j at w1.fi
Sat Mar 3 01:04:54 EST 2007


On Thu, Mar 01, 2007 at 11:16:22AM +0100, Ragnar Ch. Nevries wrote:

> I get the following error if i try to connect to 802.1x secured wifi
> network with an OpenWrt Router as client (it is an Dlink WRT54GL with
> broadcom chip).
> The version of wpa_supplicant is 0.4.7 . I think it is the same problem
> as in Bug http://hostap.epitest.fi/bugz/show_bug.cgi?id=202

Well, it is related, but not identical. The presense of WMM IE is indeed
confusing the parser, but since you are not using WPA, that should be
fine (but is not in v0.4.7).

> Please confirm this assumption and tell me if this is solved in newer
> versions or if someone is working on it.

The IE parsing problems is still open and I don't know whether anyone is
working on it. The problem of bogus WPA IE preventing use of non-WPA
mode has been resolved in v0.4.10 and v0.5.7. I would expect those
versions to resolve the issue you are seeing (i.e., non-WPA case with
WMM).

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list