Cannot compile wpa_supplicant (0.6.0 and 0.5.7) with madwifi-ng-0.9.3.1

Jouni Malinen j at w1.fi
Sun Jun 17 01:53:22 EDT 2007


On Sat, Jun 16, 2007 at 11:23:37PM +0200, Alexander Skwar wrote:

> I'm trying to use wpa_supplicant together with madwifi-ng 0.9.3.1, but
> I fail to do so... :( I'd like to use the packages from Gentoo on a 
> Gentoo Linux ~x86 system.

I have no problems building wpa_supplicant 0.5.7 or 0.6.0 with
madwifi-ng 0.9.3.1. It looks like this is your system does not have
madwifi header files where the build scripts think they should be:

> CFLAGS += -I/usr/include/madwifi
> ../src/drivers/driver_madwifi.c:27:32: error: net80211/ieee80211.h: No such file or directory

In other words, this looks like a Gentoo problem (at most). I don't see
how wpa_supplicant or madwifi-ng would be broken in any way as far as
this issue is concerned.

Anyway, you most likely do not even need the driver_madwifi.c interface
since madwifi supports Linux wireless extensions (driver_wext.c.).

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list