Using hostap WPA authenticator in a VLAN BSS

Lambert Anne anne.lambert at thomson.net
Wed Jul 25 07:15:03 EDT 2007


Hi,

Problem solved. I forgot to check that the passphrase was correct on
both sides...

Regards,

Anne Lambert 

-----Original Message-----
From: hostap-bounces+anne.lambert=thomson.net at shmoo.com
[mailto:hostap-bounces+anne.lambert=thomson.net at shmoo.com] On Behalf Of
Lambert Anne
Sent: 24 July 2007 17:13
To: hostap at shmoo.com
Subject: Using hostap WPA authenticator in a VLAN BSS

Hi,

I am building a driver which is using a part of hostapd code as WPA
Authenticator. The AP management is already taken care of so I just need
to interact directly with the wpa module for every new station.

The driver sends the EAPOL frames coming from the wpa Authenticator and
uses wpa_receive for the station's response. I have it so far working
when the network does not use VLAN. 

When VLAN is used however, the authentification fails with the message
'invalid MIC in msg 2/4 of 4-Way Handshake'. I checked the frames and am
pretty confident that the WPA module receives the correct information. I
thought that VLAN would not have an influence on the key generation, but
I am obviously mistaken! Could somebody give a hint what needs to be
initialised in the wpaAuthenticator or in the hostapd_data to have it
working?

Regards,

Anne Lambert
 
_______________________________________________
HostAP mailing list
HostAP at shmoo.com
http://lists.shmoo.com/mailman/listinfo/hostap




More information about the HostAP mailing list