problem with wpa_supplicant and WPA-NONE

Thao thao710 at yahoo.com
Thu Jul 12 08:10:00 EDT 2007


Hi all,
I try to create a ad-hoc network with 3 laptops, 3 cards Wi-Fi 3COM 3CRPAG175 and WPA-NONE:

3 PCs are used Ubuntu 6.10, madwifi and have the same configuration:
in /etc/network/interfaces:
auto ath0
iface ath0 inet static
address 192.168.0.x             (x=1,2 or 3)
netmask 255.255.255.0
wpa-conf /etc/wpa_supplicant.conf

in /etc/wpa_supplicant.conf:
eapol_version=1
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=2
network={
    ssid="testpsk"
    mode=1
    proto=WPA
    key_mgmt=WPA-NONE
    pairwise=NONE
    group=CCMP
    psk="hhhhhhhh"
}

root at laptop1:~#iwconfig ath0
ath0      IEEE 802.11g  ESSID:"testpsk"  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 02:0F:CB:B1:82:B6   
          Bit Rate:0 kb/s   Tx-Power:31 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:A83D-9695-2E28-4D15-F1C2-9B15-2E0F-0C13   Security mode:restricted
          Power Management:off
          Link Quality=32/94  Signal level=-54 dBm  Noise level=-86  dBm
          Rx invalid nwid:43656  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I try to run olsrd in laptop 1 and 2, then in laptop3.
- olsrd in laptop1 reveives only the packet diffused by olsrd in laptop 2.
- olsrd in laptop2 reveives only the packet diffused by olsrd in laptop 1.
- olsrd in laptop3 reveives only the packet diffused by olsrd in laptop 2.

PC1 <------------> PC2 ----------> PC3

It seem that in mode ad hoc with WPA-NONE, only one section is created on each interface for data transmission (2 directions). So the 3rd laptop can't communicate with 2 first laptops. Is it the problem of physical support, of madwifi or of wpa_supplicant?????
 
       
---------------------------------
Boardwalk for $500? In 2007? Ha! 
Play Monopoly Here and Now (it's updated for today's economy) at Yahoo! Games.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20070712/0acd6750/attachment.htm 


More information about the HostAP mailing list