no suitable AP found

Dan Williams dcbw at redhat.com
Tue Jan 23 09:52:15 EST 2007


On Fri, 2007-01-19 at 13:26 +0100, Peter Hartmann wrote:
> hello,
> 
> like some people before me i get an error while connecting to a wpa-tkip-
> encrypted net using the following components:
> * wpa_supplicant-0.5.7 (with driver hostap)
> * linux-wlan-ng-0.2.5
> * d-link dwl-122 or netgear ma-111
> * linux kernel 2.6.16.29
> 
> i do not really know whether the problem is at the wlan-ng-drivers or at
> wpa_supplicant; wpa_supplicant says the driver is not wpa-capable. however,
> i've heard of the wlan-ng drivers running with wpa_supplicant.
> 
> on the other side, wpa_supplicant does not seem to recognize wpa-encrypted
> nets (the one i want to use is the "FritzBox..." thing, and it is
> wpa-encrypted, other windows-machines are connected to it using wpa),
> the command "wpa_supplicant -dd -w -Dhostap -iwlan0" says:
> 
> ----
> ioctl[SIOCSIWPMKSA]: Function not implemented
> ioctl[SIOCSIWMODE]: Operation not supported
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> ioctl[PRISM2_IOCTL_HOSTAPD]: Function not implemented
> ioctl[PRISM2_IOCTL_HOSTAPD]: Function not implemented
> ioctl[PRISM2_IOCTL_HOSTAPD]: Function not implemented
> ioctl[PRISM2_IOCTL_HOSTAPD]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver  
> 'hostap' ctrl_interface 'N/A' bridge 'N/A'
> Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
> Reading configuration file '/etc/wpa_supplicant.conf'
> ctrl_interface='/var/run/wpa_supplicant'
> ctrl_interface_group='0' (DEPRECATED)
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> Line: 316 - start of a new network block
> ssid - hexdump_ascii(len=23):
>       46 52 49 54 5a 21 42 6f 78 20 46 6f 6e 20 57 4c   FRITZ!Box Fon WL
>       41 4e 20 37 31 34 31                              AN 7141
> proto: 0x1
> key_mgmt: 0x2
> group: 0x8
> PSK - hexdump(len=32): [REMOVED]
> priority=5 (0x5)
> Priority group 5
>     id=0 ssid='FRITZ!Box Fon WLAN 7141'
> Initializing interface (2) 'wlan0'
> EAPOL: SUPP_PAE entering state DISCONNECTED
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> EAPOL: SUPP_BE entering state INITIALIZE
> EAP: EAP entering state DISABLED
> EAPOL: External notification - portEnabled=0
> EAPOL: External notification - portValid=0
> Could not configure driver to use managed mode
> SIOCGIWRANGE: WE(compiled)=19 WE(source)=13 enc_capa=0x0
>    capabilities: key_mgmt 0x0 enc 0x3
> WEXT: Operstate: linkmode=1, operstate=5
> Own MAC address: 00:09:5b:67:XX:XX
> wpa_driver_hostap_set_wpa: enabled=1
> Driver does not support WPA.
> wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
> Failed to set encryption.
> wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
> Failed to set encryption.
> wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
> Failed to set encryption.
> wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
> Failed to set encryption.
> wpa_driver_hostap_set_countermeasures: enabled=0
> wpa_driver_hostap_set_drop_unencrypted: enabled=1
> Setting scan request: 0 sec 100000 usec
> ctrl_interface_group=0
> Added interface wlan0
> RTM_NEWLINK: operstate=0 ifi_flags=0x1023 ([UP])
> RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
> RTM_NEWLINK: operstate=0 ifi_flags=0x1023 ([UP])
> RTM_NEWLINK, IFLA_IFNAME:ioctl[PRISM2_IOCTL_HOSTAPD]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Function not implemented
>   Interface 'wlan0' added
> State: DISCONNECTED -> SCANNING
> Starting AP scan (broadcast SSID)
> Trying to get current scan results first without requesting a new scan  
> to speed up initial association
> Received 543 bytes of scan results (5 BSSes)
> Scan results: 5
> Selecting BSS from priority group 5
> 0: 00:15:0c:54:c2:4b ssid='...' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>     skip - no WPA/RSN IE
> 1: 00:15:0c:fa:8f:3a ssid='FRITZ!Box Fon WLAN 7141' wpa_ie_len=0  
> rsn_ie_len=0 caps=0x11
>     skip - no WPA/RSN IE

^^^ this is your problem.  The driver version you downloaded is broken,
as it does not appear to return the required WPA Information Element in
it's scan results.

This could be one of two things:

1) The driver you have is broken
2) You should be using the '-Dwext' driver, not the 'hostap' driver

I grabbed the latest sources I could fine from here:

ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/linux-wlan-ng-0.2.7.tar.bz2

and I found the function wext_translate_bss() in p80211/p80211wext.c.
That function does _NOT_ contain anything that would allow a received
WPA Information Element to be returned in scan results.

Therefore, your problem is (1) above.  I cannot see how the
linux-wlan-ng driver would _ever_ work with WPA because at least some of
the code to support it is just not there.

Dan


> 2: 00:90:96:c0:d8:b1 ssid='...' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>     skip - no WPA/RSN IE
> 3: 00:a0:c5:ec:6c:83 ssid='...' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
>     skip - no WPA/RSN IE
> 4: 00:12:17:b2:d5:19 ssid='...' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
>     skip - no WPA/RSN IE
> No suitable AP found.
> Setting scan request: 0 sec 0 usec
> .
> .
> .
> ---
> 
> any help would be really appreciated.
> 
> greetings,
> Peter
> 




More information about the HostAP mailing list