seg fault when interface does not exist

Kel Modderman kel at otaku42.de
Sat Feb 24 10:18:08 EST 2007


Hi Jouni,

On Tuesday 19 December 2006 13:25, Jouni Malinen wrote:
> On Mon, Dec 18, 2006 at 04:13:33PM +1000, Kel Modderman wrote:
> > Debian 0.5.6-1 binary. No modification to your tarball apart from a patch
> > that points to specific doc's. The following config is used (madwifi
> > headers are activated via another patch):
>
> OK, I was able to reproduce this with 0.5.6 using the included .config.
> This was fixed couple of weeks ago and I merged the fix into 0.5.x
> branch a week ago, so I believe the issue is resolved.

This issue looks like it is still there with snapshot of 0.6, 2007-02-11.

# /sbin/wpa_supplicant -i eth5 -D wext -c /etc/wpa_supplicant/wpa_supplicant-dummy.conf
ioctl[SIOCGIFFLAGS]: No such device
Could not get interface 'eth5' flags
ioctl[SIOCSIWPMKSA]: No such device
ioctl[SIOCSIWMODE]: No such device
Could not configure driver to use managed mode
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWAUTH]: No such device
WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
ioctl[SIOCSIWAUTH]: No such device
WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: No such device
WEXT auth param 4 value 0x0 - Segmentation fault

# wpa_supplicant -v
wpa_supplicant v0.6.0

Thanks, Kel.



More information about the HostAP mailing list