[PATCH] hostapd: rename driver_devicescape to driver_nl80211

Jouni Malinen j at w1.fi
Mon Dec 24 21:10:16 EST 2007


On Tue, Dec 25, 2007 at 01:48:44AM +0100, Johannes Berg wrote:

> Seriously? Debian now ships libnl 1.0-pre8 which is sufficient. Poke the
> Gentoo maintainer :)

Gentoo is still using 1.0-pre6.. Kernel update (wireless-2.6#everything)
triggered a semi-related issue since linux/ip_mp_alg.h does not seem to
exist anymore, but netlink/netlink.h from 1.0-pre8 libnl tries to
include it.. As a bonus, something triggered conflicts between
src/utils/common.h and linux/types.h which gets included when building
driver_nl80211.c. I think I resolved this, but I really do not like
including linux/* when this type of issues show up.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list