Failed to initialize wpa_supplicant

Reik Red reikred at
Sun Dec 23 15:44:33 EST 2007

Hi everybody,

In a nutshell: I cannot get init to start wpa_supplicant successfully as a service,
but I can start it manually myself after the fact. I'm trying debug this so that I
will be able to bring up wlan0 on boot.

Here's what happens during boot (after which wlan0 is not able to get an ip address):

Starting wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf,
   -iwlan0, dbus_bus_get[ctrl_iface_dbus]: No such file or directory
Failed to initialize wpa_supplicant

And here's what happens when I run it manually after boot:

#The following is the same command that "service wpa_supplicant start" generates
% wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -B -u -f
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 -

Despite the error message, wlan0 is now up and will even get itself an ip address
if I issue a "dhclient wlan0" command.

I have already tried the bit about changing 12 88 to 09 88 in the /etc/init.d/wpa_supplicant script.
# chkconfig:   - 09 88

After looking for a bout a day on the web, I'm hoping someone here knows the answer.
The only thing missing here is to be able to boot and have wlan0 come right up.


System details: Fedora 8 fc8_x86_64, kernel, yum update wpa_supplicant
is current as of today, driver used is ralink's ra61pci.

More information about the HostAP mailing list