EAP-SIM failing...

Raghavendra. S raghavendra.akkasali at gmail.com
Wed Dec 19 04:42:02 EST 2007


Hi All,

 I am trying to test EAP-SIM. using wpa supplicant 0.6.1.
I have following supplicant.conf file entry.
-----------------------start--------------------------------------------------------
ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=0


# EAP-SIM with a GSM SIM or USIM
network={
#       ssid="3Com"
        key_mgmt=WPA-EAP
        eap=SIM
        pin="1234"
        pcsc=""
        eapol_flags=0
}
-----------------------end--------------------------------------------------------

I got following failure logs.

# ifconfig eth0 up
# ./wpa_supplicant -Dwext -ieth0 -c ./files/wpa_supplicant.eap-sim -w -ddd
Initializing interface 'eth0' conf './files/wpa_supplicant.eap-sim'
driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file './files/wpa_supplicant.eap-sim' ->
'/mnt/nfs/./files/wpa_supplicant.eap-sim'
Reading configuration file '/mnt/nfs/./files/wpa_supplicant.eap-sim'
ctrl_interface='/var/run/wpa_supplicant'
eapol_version=1
ap_scan=0
Line: 7 - start of a new network block
key_mgmt: 0x1
eap methods - hexdump(len=16): 00 00 00 00 12 00 00 00 00 00 00 00 00 00 00 00
pin - hexdump_ascii(len=4): [REMOVED]
pcsc - hexdump_ascii(len=0):
eapol_flags=0 (0x0)
Priority group 0
   id=0 ssid=''
Initializing interface (2) 'eth0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Interface eth0 set UP - waiting a second for the driver to complete
initialization
ioctl[SIOCSIWPMKSA]: Invalid argument
SIOCGIWRANGE: WE(compiled)=22 WE(source)=15 enc_capa=0x0
  capabilities: key_mgmt 0x0 enc 0x3
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:13:e0:9e:9b:2e
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
ioctl[SIOCSIWPMKSA]: Invalid argument
Setting scan request: 0 sec 100000 usec
Added interface eth0
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
Wireless event: cmd=0x8b06 len=8
EAPOL: External notification - portControl=Auto
Already associated with a configured network - generating associated event
Association info event
State: DISCONNECTED -> ASSOCIATED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
Associated with 00:00:00:00:00:00
Selected network is configured to use SIM (sim=1 aka=0) - initialize PCSC
Failed to initialize SIM (pcsc-lite)
WPA: Association event - clear replay counter
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: SUPP_BE entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Cancelling scan request
EAPOL: startWhen --> 0
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
BSSID not set when trying to send an EAPOL frame
Using the source address of the last received EAPOL frame
00:00:00:00:00:00 as the EAPOL destination
TX EAPOL: dst=00:00:00:00:00:00
TX EAPOL - hexdump(len=4): 01 01 00 00
Authentication with 00:00:00:00:00:00 timed out.
Added BSSID 00:00:00:00:00:00 into blacklist
No keys have been configured - skip key clearing
State: ASSOCIATED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 0 usec
EAPOL: External notification - portControl=Auto
Already associated with a configured network - generating associated event
Association info event
State: DISCONNECTED -> ASSOCIATED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
Associated with 00:00:00:00:00:00
Selected network is configured to use SIM (sim=1 aka=0) - initialize PCSC
Failed to initialize SIM (pcsc-lite)
WPA: Association event - clear replay counter
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: SUPP_BE entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Cancelling scan request
EAPOL: startWhen --> 0
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
BSSID not set when trying to send an EAPOL frame
Using the source address of the last received EAPOL frame
00:00:00:00:00:00 as the EAPOL destination
TX EAPOL: dst=00:00:00:00:00:00
TX EAPOL - hexdump(len=4): 01 01 00 00


I configured AP for WPA-EAP. I am not getting any logs at RADIUS
server side. I am using freeradius.

-- 
Regards & Thanks
Raghavendra. S



More information about the HostAP mailing list