WEP-shared is failing...

Dan Williams dcbw at redhat.com
Mon Dec 17 22:08:09 EST 2007


On Tue, 2007-12-18 at 08:34 +0530, Raghavendra. S wrote:
> Hi Dan,
> 
>   I wonder..it started working all of a sudden. Previously I was
> getting some event...
> "Wireless event new AP 00:00:00:00:00:00", bcoz of which it was
> disconnecting. Couldn't find out why my AP was sending this. Just let
> me know in case if you have answer for this.

Sometimes APs get confused if you try to reconnect to them too
frequently back to back .  APs suck, especially consumer ones.
Frequently, power-cycling the AP or waiting a minute between connection
attempts (like when debugging this sort of stuff) helps.

Dan

>  But it works only for hex keys as you mentioned earlier.
> 
>  Thanx.
> 
> -Raghu.
> 
> On 12/18/07, Dan Williams <dcbw at redhat.com> wrote:
> > On Tue, 2007-12-18 at 07:51 +0530, Raghavendra. S wrote:
> > > Hi,
> > >
> > >    One small correction, i am using wpa supplicant-0.5.9, with -Dwext
> > > on marvell 8686. It is working for EAP methods, WEP-open...etc.
> > >    Previously  I was using marvell ported wpa supplicant 0.5.7 with
> > > -Dmarvell. Now I tried with 0.5.7 also...for that also it is failing.
> >
> > You're going to need to get debug output from the driver to figure out
> > what is going wrong in the association bits.
> >
> > Turn on DBG_INFO (see wlan_defs.h) and reply with the output you get in
> > the kernel logs.
> >
> > Dan
> >
> >
> > > -Raghu.
> > >
> > > On 12/18/07, Raghavendra. S <raghavendra.akkasali at gmail.com> wrote:
> > > > Hi,
> > > >
> > > >  Plz find "iwlist eth0 scan" - result
> > > >
> > > > # /sbin/ifconfig eth0
> > > > eth0      Link encap:Ethernet  HWaddr 00:13:E0:9E:9B:2E
> > > >          UP BROADCAST MULTICAST  MTU:1500  Metric:1
> > > >          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
> > > >          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
> > > >          collisions:0 txqueuelen:1000
> > > >          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
> > > >          Interrupt:41
> > > >
> > > > # iwlist eth0 scan
> > > > eth0      Scan completed :
> > > >          Cell 01 - Address: 00:0F:CB:FE:2F:5F
> > > >                    ESSID:"3Com"
> > > >                    Mode:Managed
> > > >                    Frequency:2.412 GHz (Channel 1)
> > > >                    Quality:0/100  Signal level=-42 dBm  Noise level=-96 dBm
> > > >                    Encryption key:on
> > > >                    Bit Rates:54 Mb/s
> > > >
> > > >
> > > > -Raghu
> > > >
> > > > On 12/18/07, Dan Williams <dcbw at redhat.com> wrote:
> > > > > On Tue, 2007-12-18 at 07:40 +0530, Raghavendra. S wrote:
> > > > > > Hi,
> > > > > >
> > > > > >   Tried with hex key...still failing...
> > > > > > ----------------------------------------------------------------------------------
> > > > > > ctrl_interface=/var/run/wpa_supplicant
> > > > > > ap_scan=1
> > > > > >
> > > > > > network={
> > > > > >         ssid="3Com"
> > > > > >         key_mgmt=NONE
> > > > > >         wep_key0=76F6B7657D
> > > > > >         wep_tx_keyidx=0
> > > > > >         auth_alg=SHARED
> > > > > > }
> > > > > > ----------------------------------------------------------------------------------------
> > > > > >
> > > > > > if you see below log...i have following three lines...
> > > > > >
> > > > > > ioctl[SIOCSIWFREQ]: Operation not supported
> > > > > > ioctl[SIOCSIWESSID]: Network is unreachable
> > > > > > ioctl[SIOCSIWAP]: Network is unreachable
> > > > >
> > > > > The Marvell vendor driver returns ENETUNREACH from SIOCSIWESSID adn
> > > > > SIOCSIWAP when it can't find the SSID to associate with, or when the
> > > > > security parameters of the network don't match what the driver has been
> > > > > configured for.  Basically, the configuration you have and the scan
> > > > > result that the driver has don't match up, or the network wasn't found
> > > > > during the pre-association scan.  Can you provide the output of 'iwlist
> > > > > ethX scan' for the 3Com network you want to connect to?
> > > > >
> > > > > Dan
> > > > >
> > > > > > is this a problem..or some thing else?
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > On 12/18/07, Dan Williams <dcbw at redhat.com> wrote:
> > > > > > > On Tue, 2007-12-18 at 07:22 +0530, Raghavendra. S wrote:
> > > > > > > > Hi All,
> > > > > > > >
> > > > > > > >  I tried to test wpa supplicant for auth_alg=SHARED, but failing to
> > > > > > > > connect with AP,
> > > > > > > > My supplicant.conf file configuration is all below.
> > > > > > > >
> > > > > > > > ----------------------start------------------------------------------------------------------
> > > > > > > >
> > > > > > > > ctrl_interface=/var/run/wpa_supplicant
> > > > > > > >
> > > > > > > > network={
> > > > > > > >         ssid="3Com"
> > > > > > > >         key_mgmt=NONE
> > > > > > > >         auth_alg=SHARED
> > > > > > > >         wep_key0="raghu123456"
> > > > > > >
> > > > > > > Are you trying to use a WEP passphrase here?  I don't think
> > > > > > > wpa_supplicant supports WEP passphrase hashing.  Try a hex key here
> > > > > > > instead.
> > > > > > >
> > > > > > > Dan
> > > > > > >
> > > > > > >
> > > > > > > >         wep_tx_keyidx=0
> > > > > > > > }
> > > > > > > > ----------------------end-------------------------------------------------------------------
> > > > > > > >
> > > > > > > > I got following failure logs,
> > > > > > > >
> > > > > > > > # ./wpa_supplicant -ieth0 -Dwext -c ./files/wpa_supplicant.sharedWEP -w -ddd
> > > > > > > > Initializing interface 'eth0' conf './files/wpa_supplicant.sharedWEP'
> > > > > > > > driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
> > > > > > > > Configuration file './files/wpa_supplicant.sharedWEP' ->
> > > > > > > > '/mnt/nfs/./files/wpa_supplicant.sharedWEP'
> > > > > > > > Reading configuration file '/mnt/nfs/./files/wpa_supplicant.sharedWEP'
> > > > > > > > ctrl_interface='/var/run/wpa_supplicant'
> > > > > > > > Line: 4 - start of a new network block
> > > > > > > > ssid - hexdump_ascii(len=4):
> > > > > > > >      33 43 6f 6d                                       3Com
> > > > > > > > key_mgmt: 0x4
> > > > > > > > auth_alg: 0x2
> > > > > > > > wep_key0 - hexdump(len=11): [REMOVED]
> > > > > > > > wep_tx_keyidx=0 (0x0)
> > > > > > > > Priority group 0
> > > > > > > >    id=0 ssid='3Com'
> > > > > > > > Initializing interface (2) 'eth0'
> > > > > > > > EAPOL: SUPP_PAE entering state DISCONNECTED
> > > > > > > > EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> > > > > > > > EAPOL: SUPP_BE entering state INITIALIZE
> > > > > > > > EAP: EAP entering state DISABLED
> > > > > > > > EAPOL: External notification - portEnabled=0
> > > > > > > > EAPOL: External notification - portValid=0
> > > > > > > > ioctl[SIOCSIWPMKSA]: Invalid argument
> > > > > > > > SIOCGIWRANGE: WE(compiled)=22 WE(source)=15 enc_capa=0x0
> > > > > > > >   capabilities: key_mgmt 0x0 enc 0x3
> > > > > > > > WEXT: Operstate: linkmode=1, operstate=5
> > > > > > > > Own MAC address: 00:13:e0:9e:9b:2e
> > > > > > > > wpa_driver_wext_set_wpa
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_countermeasures
> > > > > > > > wpa_driver_wext_set_drop_unencrypted
> > > > > > > > Setting scan request: 0 sec 100000 usec
> > > > > > > > Added interface eth0
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b06 len=8
> > > > > > > > State: DISCONNECTED -> SCANNING
> > > > > > > > Starting AP scan (broadcast SSID)
> > > > > > > > Trying to get current scan results first without requesting a new scan
> > > > > > > > to speed up initial association
> > > > > > > > Received 416 bytes of scan results (5 BSSes)
> > > > > > > > Scan results: 5
> > > > > > > > Selecting BSS from priority group 0
> > > > > > > > Try to find WPA-enabled AP
> > > > > > > > 0: 00:90:4c:91:00:01 ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 1: 00:0f:cb:fe:2f:5f ssid='3Com' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 2: 02:1b:77:03:c6:24 ssid='Enaru_Ser' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 3: 02:e0:98:04:50:3e ssid='kk' wpa_ie_len=0 rsn_ie_len=0 caps=0x2
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 4: 00:1c:10:21:94:bb ssid='linksysWRT150N' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > Try to find non-WPA AP
> > > > > > > > 0: 00:90:4c:91:00:01 ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    skip - SSID mismatch
> > > > > > > > 1: 00:0f:cb:fe:2f:5f ssid='3Com' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    selected non-WPA AP 00:0f:cb:fe:2f:5f ssid='3Com'
> > > > > > > > Trying to associate with 00:0f:cb:fe:2f:5f (SSID='3Com' freq=2412 MHz)
> > > > > > > > Cancelling scan request
> > > > > > > > WPA: clearing own WPA/RSN IE
> > > > > > > > Automatic auth_alg selection: 0x1
> > > > > > > > Overriding auth_alg selection: 0x2
> > > > > > > > WPA: clearing AP WPA IE
> > > > > > > > WPA: clearing AP RSN IE
> > > > > > > > WPA: clearing own WPA/RSN IE
> > > > > > > > No keys have been configured - skip key clearing
> > > > > > > > wpa_driver_wext_set_key: alg=1 key_idx=0 set_tx=1 seq_len=0 key_len=11
> > > > > > > > wpa_driver_wext_set_drop_unencrypted
> > > > > > > > State: SCANNING -> ASSOCIATING
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > wpa_driver_wext_associate
> > > > > > > > ioctl[SIOCSIWFREQ]: Operation not supported
> > > > > > > > ioctl[SIOCSIWESSID]: Network is unreachable
> > > > > > > > ioctl[SIOCSIWAP]: Network is unreachable
> > > > > > > > Association request to the driver failed
> > > > > > > > Setting authentication timeout: 5 sec 0 usec
> > > > > > > > EAPOL: External notification - portControl=ForceAuthorized
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b06 len=8
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b15 len=20
> > > > > > > > Wireless event: new AP: 00:00:00:00:00:00
> > > > > > > > Added BSSID 00:0f:cb:fe:2f:5f into blacklist
> > > > > > > > CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
> > > > > > > > State: ASSOCIATING -> DISCONNECTED
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > EAPOL: External notification - portEnabled=0
> > > > > > > > EAPOL: External notification - portValid=0
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b15 len=20
> > > > > > > > Wireless event: new AP: 00:00:00:00:00:00
> > > > > > > > Added BSSID 00:00:00:00:00:00 into blacklist
> > > > > > > > CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
> > > > > > > > State: DISCONNECTED -> DISCONNECTED
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > EAPOL: External notification - portEnabled=0
> > > > > > > > EAPOL: External notification - portValid=0
> > > > > > > > Authentication with 00:00:00:00:00:00 timed out.
> > > > > > > > BSSID 00:00:00:00:00:00 blacklist count incremented to 2
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> > > > > > > > wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> > > > > > > > State: DISCONNECTED -> DISCONNECTED
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > EAPOL: External notification - portEnabled=0
> > > > > > > > EAPOL: External notification - portValid=0
> > > > > > > > Setting scan request: 0 sec 0 usec
> > > > > > > > State: DISCONNECTED -> SCANNING
> > > > > > > > Starting AP scan (broadcast SSID)
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b19 len=8
> > > > > > > > Received 416 bytes of scan results (5 BSSes)
> > > > > > > > Scan results: 5
> > > > > > > > Selecting BSS from priority group 0
> > > > > > > > Try to find WPA-enabled AP
> > > > > > > > 0: 00:90:4c:91:00:01 ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 1: 00:0f:cb:fe:2f:5f ssid='3Com' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 2: 02:1b:77:03:c6:24 ssid='Enaru_Ser' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 3: 02:e0:98:04:50:3e ssid='kk' wpa_ie_len=0 rsn_ie_len=0 caps=0x2
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > 4: 00:1c:10:21:94:bb ssid='linksysWRT150N' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
> > > > > > > >    skip - no WPA/RSN IE
> > > > > > > > Try to find non-WPA AP
> > > > > > > > 0: 00:90:4c:91:00:01 ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    skip - SSID mismatch
> > > > > > > > 1: 00:0f:cb:fe:2f:5f ssid='3Com' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
> > > > > > > >    selected non-WPA AP 00:0f:cb:fe:2f:5f ssid='3Com'
> > > > > > > > Trying to associate with 00:0f:cb:fe:2f:5f (SSID='3Com' freq=2412 MHz)
> > > > > > > > Cancelling scan request
> > > > > > > > WPA: clearing own WPA/RSN IE
> > > > > > > > Automatic auth_alg selection: 0x1
> > > > > > > > Overriding auth_alg selection: 0x2
> > > > > > > > WPA: clearing AP WPA IE
> > > > > > > > WPA: clearing AP RSN IE
> > > > > > > > WPA: clearing own WPA/RSN IE
> > > > > > > > No keys have been configured - skip key clearing
> > > > > > > > wpa_driver_wext_set_key: alg=1 key_idx=0 set_tx=1 seq_len=0 key_len=11
> > > > > > > > wpa_driver_wext_set_drop_unencrypted
> > > > > > > > State: SCANNING -> ASSOCIATING
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > wpa_driver_wext_associate
> > > > > > > > ioctl[SIOCSIWFREQ]: Operation not supported
> > > > > > > > ioctl[SIOCSIWESSID]: Network is unreachable
> > > > > > > > ioctl[SIOCSIWAP]: Network is unreachable
> > > > > > > > Association request to the driver failed
> > > > > > > > Setting authentication timeout: 5 sec 0 usec
> > > > > > > > EAPOL: External notification - portControl=ForceAuthorized
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b06 len=8
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b15 len=20
> > > > > > > > Wireless event: new AP: 00:00:00:00:00:00
> > > > > > > > BSSID 00:0f:cb:fe:2f:5f blacklist count incremented to 2
> > > > > > > > CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
> > > > > > > > State: ASSOCIATING -> DISCONNECTED
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > EAPOL: External notification - portEnabled=0
> > > > > > > > EAPOL: External notification - portValid=0
> > > > > > > > RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> > > > > > > > Wireless event: cmd=0x8b15 len=20
> > > > > > > > Wireless event: new AP: 00:00:00:00:00:00
> > > > > > > > BSSID 00:00:00:00:00:00 blacklist count incremented to 3
> > > > > > > > CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
> > > > > > > > State: DISCONNECTED -> DISCONNECTED
> > > > > > > > wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> > > > > > > > WEXT: Operstate: linkmode=-1, operstate=5
> > > > > > > > EAPOL: External notification - portEnabled=0
> > > > > > > > EAPOL: External notification - portValid=0
> > > > > > > >
> > > > > > > >
> > > > > > > > Please tell me why it is failing?
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Regards & Thanks
> > > > Raghavendra. S
> > > >
> > >
> > >
> >
> >
> 
> 




More information about the HostAP mailing list