When will wpa supplicant 0.6.0 stable version get released?

Raghavendra. S raghavendra.akkasali at gmail.com
Sun Dec 16 22:21:54 EST 2007


On 12/17/07, Jouni Malinen <j at w1.fi> wrote:
> On Mon, Dec 17, 2007 at 07:38:05AM +0530, Raghavendra. S wrote:
>
> >   Can any body tell me when will 0.6.0 stable version will get
> > realeased.
>
> 0.6.0 will never be released as a stable version, but some later 0.6.x
> version will (or well, maybe it will end up being renumbered to 1.0.0 at
> that point, but anyway). However, I do not have a good estimate on when
> this would happen. In theory, I would like to get this released soon,
> but in practice, there is still number of open cleanup tasks that I
> would prefer to get into bit more complete state before declaring 0.6.x
> stable (which would also mean locking down many of the APIs and prevent
> the planned cleanups in this branch).
>
> > Also can I start using 0.6.0 in my device? Whether its
> > going to harm in some way. or its better to wait for stable version
> > release.
>
> That's something that you will need to decide for yourself depending on
> the exact requirements of the project. I'm using 0.6.x versions in my
> daily use without any problems and I think that some Linux distributions
> are also using something from 0.6.x branch.
>
> If you want to play things safe and be more conservative, the latest
> stable branch may be the best choice. However, if you need some new
> features that are only available from the development branch, you may
> have to consider using the development branch (or be prepared to
> backport some of the features to an older branch).
>
> In general, I expect wpa_supplicant development branch to be suitable
> for general use all the time since my policy is not to commit partial
> changes there. The main reason for having a separate development branch
> is in having no limits on what kind of cleanup can be done. For example,
> I just changed one of the internal APIs (EAP method interface) that
> resulted in huge number of small changes throughout the code. This is
> something that I won't be doing in stable branches, but still, the
> change itself is not expected to bring much instability from the view
> point of just using wpa_supplicant binary.


  I need to provide support for Adhoc network creation and Adhoc
connection. Some time back Dan Williams has replied me that these are
not supported in version 0.5.x. So I am planning to use 0.6.x..I am
not very particular about using 0.6.0. Can you suggest me which of
0.6.x version is safe to use.

 Also I am planning to modify wpa_cli, as thread and will use in my
product, Is there any Licensing issue involved? I am not modifying
wpa_supplicant binary.


>
> The main "instability" comes from the view point of maintaining external
> changes. This is going to be very much more work if done against a
> development branch.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>


-- 
Regards & Thanks
Raghavendra. S



More information about the HostAP mailing list