Ndiswrapper and virtual interfaces - WPA_supplicant can't associate

Dudy Kohen kohen.d at gmail.com
Sat Dec 15 07:11:56 EST 2007


Thank you,
I set those parameters now and realized what the problem is...
with the card that works I get this output in debug mode:
0: 00:1a:XX:XX:XX:XX ssid='dd-wrt_wpa' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
   selected based on WPA IE
with the one that doesn't work I get this:
0: 00:1a:XX:XX:XX:XX ssid='dd-wrt_wpa' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE

Any idea as to why?
Thanks again,
David
> Date: Thu, 13 Dec 2007 19:41:43 -0800
> From: Jouni Malinen <j at w1.fi>
> Subject: Re: Ndiswrapper and virtual interfaces - WPA_supplicant can't
>         associate
> To: hostap at shmoo.com
> Message-ID: <20071214034143.GW5698 at jm.kir.nu>
> Content-Type: text/plain; charset=us-ascii
>
> On Wed, Dec 12, 2007 at 03:51:27PM +0200, Dudy Kohen wrote:
>
> > I have a TrendNET 421PC and a Prism2 based card.
> > I use a Linksys WRT54GL 1.0 router with DD-WRT and a virtual interface
> > using WPA. (another with WEP, but it's for WDS)
> > Wpa_supplicant claims not to find the appropriate SSID although it
> > shows it in the debug output.
>
> That would probably be caused by a mismatch in security parameters.
>
> > Tried the ap_scan option, it didn't work any better.
>
> What do you mean with this? Did you try setting ap_scan=2 (required for
> NDIS drivers when using hidden SSIDs and multi-SSID configuration) and
> configuring key_mgmt, proto, pairwise, group to match with the AP
> configuration (only one option allowed for each parameter in ap_scan=2
> mode)?
>
> --
> Jouni Malinen                                            PGP id EFC895FA
>
>



More information about the HostAP mailing list