problems with wep and wpa

Martin Berg martin at emilldev.com
Mon Aug 20 12:48:38 EDT 2007


Hi

I have a laptop with a builtin broadcom wlan card, and I've gotten this to 
work with ndiswrapper and wpa_supplicant on an open wlan. Open wlans are 
generally a bad idea, so I tried with wep and wpa, but that didn't go so 
well. I attach my config and the output from running wpa_supplicant. 

Funny is that when the router is set to open and I activate the wlan on the 
laptop, the wlan-diod starts blinking like crazy. If I activate encryption, 
this doesn't happen. Also, iwlist scan only finds the AP if I set it to open, 
no idea why. 
-------------- next part --------------

################# /etc/wpa_supplicant.conf

update_config=1
ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=0
fast_reauth=1

network={
	ssid="utankrypt"
	key_mgmt=NONE
}

network={
	ssid="medkrypt"
	wep_key0="deuce"
	wep_key1="kalas"
	wep_key2="bengt"
	wep_key3="natas"
	key_mgmt=NONE
	auth_alg=SHARED
}

network={
	ssid="famberg"
	psk="Lill-sund"
	priority="5"
}

network={
	ssid="wpatest"
	psk="dumdumdum"
	key_mgmt=WPA-PSK
	proto=WPA
}


################ running wpa_supplicant

localhost etc # wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -dd
Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver
'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
update_config=1
ctrl_interface='/var/run/wpa_supplicant'
eapol_version=1
ap_scan=0
fast_reauth=1
Line: 42 - start of a new network block
ssid - hexdump_ascii(len=9):
     75 74 61 6e 6b 72 79 70 74                        utankrypt
key_mgmt: 0x4
Line: 47 - start of a new network block
ssid - hexdump_ascii(len=8):
     6d 65 64 6b 72 79 70 74                           medkrypt
wep_key0 - hexdump(len=5): [REMOVED]
wep_key1 - hexdump(len=5): [REMOVED]
wep_key2 - hexdump(len=5): [REMOVED]
wep_key3 - hexdump(len=5): [REMOVED]
key_mgmt: 0x4
auth_alg: 0x2
Line: 58 - start of a new network block
ssid - hexdump_ascii(len=7):
     66 61 6d 62 65 72 67                              famberg
PSK (ASCII passphrase) - hexdump_ascii(len=9): [REMOVED]
priority=0 (0x0)
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Line: 64 - start of a new network block
ssid - hexdump_ascii(len=7):
     77 70 61 74 65 73 74                              wpatest
PSK (ASCII passphrase) - hexdump_ascii(len=9): [REMOVED]
key_mgmt: 0x2
proto: 0x1
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='utankrypt'
   id=1 ssid='medkrypt'
   id=2 ssid='famberg'
   id=3 ssid='wpatest'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=21 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:14:a4:38:f8:c9
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
Setting scan request: 0 sec 100000 usec
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added


More information about the HostAP mailing list