Problems with hostap and missing wlan0 on Fedora 5

Per Weisteen per at weisteen.net
Thu Sep 21 18:45:51 EDT 2006


Hi

Somehow I've managed to remove the wlan0 device from my Fedora 5
installation. I'm not sure if this happened during my attempt to define
correct parameters for the wifi0 device and me actually removing the
wlan0 device intentionally or if it happended during the first yum based
upgrade. Since on my old 2.4 kernel I only had a wifi0 I didn't check
the README info on how the new hostap module actually generated two
devices. Anyhow, I now need some help in defining the wlan0 device
because it doesn't turn up any more.

modprobe.conf

alias eth0 3c59x
alias eth1 e100
alias scsi_hostadapter sym53c8xx
alias eth2 hisax
alias wifi0 hostap_pci
alias snd-card-0 snd-via82xx
options snd-card-0 index=0 
options snd-via82xx index=0 
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx


The relevant info from lsmod are :

ipv6                  243937  22
lp                     12937  0
usb_storage            69153  1
uhci_hcd               23885  0
floppy                 58437  0
sg                     34525  0
serio_raw               7621  0
snd_via82xx            28377  1
gameport               16201  1 snd_via82xx
hostap_pci             57717  0
hostap                113737  1 hostap_pci
ieee80211_crypt         6849  1 hostap
orinoco_pci             7885  0
orinoco                40533  1 orinoco_pci
snd_ac97_codec         92257  1 snd_via82xx
hermes                  8129  2 orinoco_pci,orinoco
  

-- 
Per Weisteen        !Email: per at weisteen.net
Telegrafalléen 8    !Phone:    (+47) 3212 2800
NO-3510 Hønefoss    !Cellular: (+47) 9344 5312
Norway






More information about the HostAP mailing list