wpa_supplicant && mandriva 2007

robm rob.merritt at usask.ca
Wed Oct 25 01:02:18 EDT 2006


its  2.6.15-27-386  so I am a candidate for candidate for a kernel upgrade.



Dan Williams wrote:

>On Tue, 2006-10-24 at 16:44 -0600, robm wrote:
>  
>
>>Both of these cards ario_cs and orinoco_cs are b only cards so  know 
>>they won't work with wpa. Can I get them to work with dynamic WEP and
>>PEAP?
>>    
>>
>
>Airo certainly will work with WPA on Windows.  It's not a function of
>being just a 802.11 B card, it's a function of the firmware.  You can do
>WPA on a B-only card just fine, you'll just never get anything over
>11Mb/s throughput.  It just happened that by the time WPA became
>popular, all the cards were B/G anyway.  But companies like Cisco that
>had installed bases in enterprises added WPA to their B-only cards with
>firmware updates.
>
>Matthieu Castet started to reverse-engineer the WPA-capable firmware
>interface for Airo cards that's in firmware versions 5.30.17 and later.
>I've pushed some patches for that upstream to the airo driver, namely
>detection of WPA-capable firmware, and reporting WPA Information
>Elements in scan results.  But the actual WPA operation is still
>unimplemented in the Linux driver.
>
>Again, try a kernel 2.6.17 or later.  Messages from your logs, like:
>
>WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
>
>indicate that you're not running the correct version of the kernel to
>get the airo driver that fixes most of the errors wpa_supplicant spews.
>
>What kernel version _are_ you running?
>
>Dan
>
>  
>
>>as per my wpa_supplicant.conf below
>>
>># IEEE 802.1X with dynamic WEP keys using EAP-PEAP/MSCHAPv2
>>
>>ctrl_interface=/var/run/wpa_supplicant
>>
>>network={
>>        ssid="uni"
>>        key_mgmt=IEEE8021X
>>        eap=PEAP
>>        phase2="auth=MSCHAPV2"
>>        identity="username"
>>        password="password"
>>}
>>
>># opennet>network={
>>        ssid=""
>> key_mgmt=NONE
>>        priority=2
>>}
>>
>>
>>
>>
>>
>>Pavel Roskin wrote:
>>
>>    
>>
>>>On Tue, 2006-10-24 at 16:17 -0600, robm wrote:
>>> 
>>>
>>>      
>>>
>>>>Ok I will try that , so would I still use
>>>>
>>>>-Dwext
>>>>
>>>>as well anyone using an orinoco_cs out there should  work for it too?
>>>>   
>>>>
>>>>        
>>>>
>>>Orinoco driver doesn't support WPA yet.
>>>
>>> 
>>>
>>>      
>>>
>
>  
>




More information about the HostAP mailing list