hostap+wpa_supplicant can't connect

Luis A. Montes luis.montes at dslextreme.com
Sun Oct 15 02:54:06 EDT 2006


Hi there.

I've been googling for an answer to my problems but haven't found
anything yet. Not sure where the problem lies, if with hostap,
wpa_supplicant or the wireless drivers, but I think there is a slight
better chance of being with wpa_supplicant.
I have an AP (old pentium computer) running hostap using the madwifi
drivers. I had it working before using plain WEP, so hardware-wise seems
fine. I want to connect to it with my laptop, a dell using a ipw2100
card. I've downloaded the latest drivers for both the AP and the laptop,
as well as the latest versions of hostap and wpa_supplicant. If I run
the AP and use windows on the laptop, I can connect using WPA, so I
think my AP is working fine. It does seem a bit flaky,the connection is
slow, and sometimes I have to click twice on a web link in order to get
it to load, but it basically works. If I boot linux (running the kernel
2.6.18) wpa_supplicant doesn't seem able to connect. No ping. Running in
the foreground (I did find using google that I had to use -Dwext with
the new versions of the ipw2100 driver) with full output enabled the
only thing that jumps out is the line:

No keys have been configured - skip key clearing

But I do have the key in my /etc/wpa_supplicant.conf file. So it
associates, but can't connect:

WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
Authentication with 00:0f:3d:ac:5f:6e timed out.
Added BSSID 00:0f:3d:ac:5f:6e into blacklist
State: ASSOCIATED -> DISCONNECTED

On the AP side, hostap keeps printing every 10 secs:

  New STA
No WPA/RSN information element for station!?
Wireless event: cmd=0x8c04 len=20
Wireless event: cmd=0x8c03 len=20

That, to the untrained eye, seems to be related to the wpa_supplicant
error, but I just don't know where the problem might be. I would be most
grateful if anybody can elucidate the meaning of these lines for me.

I' attaching the complete wpa_supplicant output, in case I missed something.

TIA,

Luis
-------------- next part --------------
A non-text attachment was scrubbed...
Name: wpa_supplicant.log
Type: text/x-log
Size: 15211 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20061014/2dffacf0/attachment.bin 


More information about the HostAP mailing list