wpa_supplicant -> EAP-TTLS/PAP, madwifi-ng (Atheros), problem

Jouni Malinen jkmaline at cc.hut.fi
Wed Oct 11 22:53:17 EDT 2006


On Wed, Oct 11, 2006 at 07:04:45PM +0200, sabx wrote:

>                     IE: WPA Version 1
>                         Group Cipher : WEP-40
>                         Pairwise Ciphers (1) : WEP-40
>                         Authentication Suites (1) : 802.1x

That's invalid WPA information element. WEP-40 is not an allow pairwise
cipher suite. If the AP is really sending out that kind of information,
it is quite broken..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list