Madwifi + wpa_supplicant (cannot get IP)

Kel Modderman kelmo at kanotixguide.org
Tue Nov 28 20:56:43 EST 2006


On Wednesday 29 November 2006 11:44, Carlos Moffat wrote:
> Hi,
>
> I'm having trouble using network-manager, and the problem seems to be
> with the interaction of wpa_supplicant and madwifi.
>
> I'm using wpa_supplicant v0.5.5 and madwifi 0.9.2 (r1809) with a 2.6.17
> kernel. For starters, I'm trying to get dhcp to work, that is, connect
> to a completely open AP (no WEP, WPA, etc). This does not seems to work.
> I have the following config:
>
> ctrl_interface=/var/run/wpa_supplicant
> eapol_version=1
> ap_scan=1
> fast_reauth=1
>
> network={
>        ssid="Patagonia"
>        key_mgmt=NONE
>        auth_alg=OPEN
>  }
>
> and try (with network-manager turned off and just after modprobing
> madwifi, just in case):
>
>  wpa_supplicant -iath0 -cwpa_supplicant.conf -d

You did not specify driver type (-Dwext for new madwifi), so wpa_supplicant 
assumes you want the default driver type `hostap' which is obviously wrong.

>
> wpa_supplicant -iath0 -cwpa_supplicant.conf -d
> Initializing interface 'ath0' conf 'wpa_supplicant.conf' driver
> 'default' ctrl_interface 'N/A' bridge 'N/A'
> Configuration file 'wpa_supplicant.conf' ->
> '/home/cmoffat/wpa_supplicant.conf'
> Reading configuration file '/home/cmoffat/wpa_supplicant.conf'
> ctrl_interface='/var/run/wpa_supplicant'
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> Priority group 0
>    id=0 ssid='Patagonia'
> Initializing interface (2) 'ath0'
> EAPOL: SUPP_PAE entering state DISCONNECTED
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> EAPOL: SUPP_BE entering state INITIALIZE
> EAP: EAP entering state DISABLED
> EAPOL: External notification - portEnabled=0
> EAPOL: External notification - portValid=0
> SIOCGIWRANGE: WE(compiled)=20 WE(source)=13 enc_capa=0xf
>   capabilities: key_mgmt 0xf enc 0xf
> WEXT: Operstate: linkmode=1, operstate=5
> Own MAC address: 00:05:4e:50:7d:bd
> wpa_driver_hostap_set_wpa: enabled=1
> wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0
> key_len=0
> ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
> Failed to set encryption.

And you get many messages like this due to using wrong driver type.

Thanks, Kel.



More information about the HostAP mailing list