current CVS breaks with madwifi

Kel Modderman kelmo at kanotixguide.org
Tue Nov 28 07:08:07 EST 2006


On Monday 20 November 2006 03:14, Jouni Malinen wrote:
> On Tue, Nov 14, 2006 at 08:33:33PM +1000, Kel Modderman wrote:
> > On Thursday 12 October 2006 10:49, Matt Brown wrote:
> > > The current CVS version does not work with madwifi, in either plain
> > > text or encrypted mode. The error is:
> > >
> > > Flushing old station entries
> > > madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
> > > ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
> >
> > Reproduced here with recent madwifi and current hostapd CVS.
>
> What exactly do you mean with the "current hostapd CVS"? v0.5.5 may
> refuse to start, but the current CVS tree version ignores errors from
> hostapd_flush_old_stations(). This was fixed more than a month ago.

You are dead right Jouni. Obviously I was full of hot air and not using an up 
to date cvs snapshot tarball.

Working well with 0.5.6.

Thanks, Kel.



More information about the HostAP mailing list