WAP-PSK TKIP connection woes

Jouni Malinen jkmaline at cc.hut.fi
Sat Nov 18 17:09:06 EST 2006


On Thu, Nov 16, 2006 at 10:13:09AM -0500, Michael S wrote:

> I am using FreeBSD 6.1-RELEASE and wpa_supplicant 0.4.8 to connect to a
> Linksys wireless router doing WPA-PSK TKIP encryption via a ndis0
> interface.

> I successfully have ndis0 configured and functioning and can scan my AP

> However, I cannot get wpa_supplicant to connect to my AP under any
> configuration. I ran wpa_supplicant with the -dd option but see nothing
> that stands out. I'm hoping that someone can help.

Could you please send debug output from the -dd case?

> network={
>    ssid="linksys"
>    bssid:00:12:17:d1:7a:17

This should be bssid=...

>    proto=WPA
>    key_mgmt=WPA-PSK
>    pairwise=TKIP
>    group="TKIP"

This should be group=TKIP

>    scan_ssid=0   # scan_ssid=1 prodes a kernel trap and page fault

Please report this to FreeBSD maintainers. That sounds like a kernel bug
(or a bug in the NDIS driver or glue code for it)..

> running wpa_supplicant -i ndis0 -c /eta/wpa_supplicant
> ------------------------------------------------------
> Trying to associate with 00:12:17:d1:7a:17 (SSID='linksys' freq=2437 MHz)
> Authentication with 00:00:00:00:00:00 timed out
> 
> wlan_tkip.ko is loaded
> 
> I cannot physically type the output of -dd and cannot paste the output
> because obviously I dont have a net connection. But, I can respond with
> specific questions about the output of -dd if it helps

I need to see that debug log to be able to help with this. Can't you
just direct the output to a file and then send that file?

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list