prism2_config() failed... (Consulted FAQ's and Mailing archive but still could not resolve)

Fawad Nazir fawad.nazir at gmail.com
Tue May 23 22:22:51 EDT 2006


On 5/23/06, Jar <jar at pcuf.fi> wrote:
> Fawad Nazir wrote:
> > I download all the files from this link
> > http://linux.junsun.net/intersil-prism/firmware/1.7.4/
> >
> > and placed them in /lib/hotplug/firmware and also to /lib/firmware
> >
> > but this problem is still also there.
>
> No, read the junsun's HOWTO once again. There are two kind of firmware
> files: RAM (volatile) and FLASH (non-volatile). You will need correct
> firmware files for your card and prism2_srec "fw-loader" utility from
> hostap-utils package.

I downloaded the hostap-utils and tried to load the firmware using
prism_srec, the following are the step i followed:

fawad at Ubuntu-01:/lib/firmware$ sudo hostap_diag wlan0
Host AP driver diagnostics information for 'wlan0'

NICID: id=0x800c v1.0.0 (PRISM II (2.5) PCMCIA (SST parallel flash))
PRIID: id=0x0015 v1.1.0
STAID: id=0x001f v1.4.9 (station firmware)
fawad at Ubuntu-01:/lib/firmware$

-------------------
I checked the mapping on this site:
http://linux.junsun.net/intersil-prism/IDtable.html

As my NICID is : 800c so i need f type of driver.
-------------------
Them i tried to load all three of these firmwares:

fawad at Ubuntu-01:/lib/firmware$ ls sf*
sf010409.hex  sf010704.hex  sf010804.hex

---------------------------------------

fawad at Ubuntu-01:/lib/firmware$ sudo prism2_srec -f wlan0 sf010704.hex
srec summary for sf010704.hex
Component: 0x001f 1.7.4 (station firmware)


Verifying update compatibility and combining data:
OK.

Downloading to non-volatile memory (flash).
Note! This can take about 30 seconds. Do _not_ remove card during download.
Odd.. Download request for the kernel driver failed.
Are you sure you have compiled (and loaded the correct version of)
hostap.o module with PRISM2_DOWNLOAD_SUPPORT definition in
driver/module/hostap_config.h?
In addition, non-volatile download requires PRISM2_NON_VOLATILE_DOWNLOAD
to be defined.
ioctl[PRISM2_IOCTL_DOWNLOAD]: Operation not supported

Download failed!

How could i solve this issue. Do i need to downlaod and make hostap
driver again?
Currently i am using the buit-in driver in Linux 2.6.16.5.

Thanks for your help.

> Best Regards, Jar
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>


-- 
Fawad Nazir



More information about the HostAP mailing list