WPA-PSK, madwifi & WAP-4000

k0STEk kostek at ustka.org
Tue May 23 03:17:10 EDT 2006


Hi!

I have problem associating planet-8310 (atheros) card with WAP-4000 
using WPA-PSK.
WAP-4000 is AP with hidden SSID

wpa_supplicant version I've tried: 0.4.9, 0.5.3
madwifi: current
Kernel: 2.6.16.17

wpa_supplicant.conf:
ap_scan=2
network={
       ssid="vabank"
       psk=3e1136fa623cead818de40825be455b90cfcad6bb755ccc03c405exxxxxxxxxx
       key_mgmt=WPA-PSK
       proto=WPA
}

Here is log from wpa_supplicant:
Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 
'madwifi' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ap_scan=2
Line: 2 - start of a new network block
ssid - hexdump_ascii(len=6):
    76 61 62 61 6e 6b                                 vabank
PSK - hexdump(len=32): [REMOVED]
key_mgmt: 0x2
proto: 0x1
Priority group 0
  id=0 ssid='vabank'
Initializing interface (2) 'ath0'
SIOCGIWRANGE: WE(compiled)=19 WE(source)=13 enc_capa=0xf
 capabilities: key_mgmt 0xf enc 0xf
Own MAC address: 00:30:4f:4a:d3:a6
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_set_countermeasures: enabled=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface ath0
Wireless event: cmd=0x8b06 len=8
Ignore event for foreign ifindex 4
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
State: DISCONNECTED -> SCANNING
Trying to associate with SSID 'vabank'
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: No WPA/RSN IE available from association info
WPA: Set cipher suites based on configuration
WPA: Selected cipher suites: group 30 pairwise 24 key_mgmt 2
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: using GTK CCMP
WPA: using PTK CCMP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 
00 50 f2 04 01 00 00 50 f2 04 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
State: SCANNING -> ASSOCIATING
wpa_driver_madwifi_associate
Setting authentication timeout: 60 sec 0 usec
Wireless event: cmd=0x8b1a len=15

Please reply ASAP
Best regards
k0stek



More information about the HostAP mailing list