HostAP dies slowly

Nick Kochakian nickk at nerdshack.com
Wed May 17 13:58:22 EDT 2006


I'm using a Prism 2.5 card with update firmware. I've tried both 
hostap-0.4.7 and hostap-0.4.4-kernel and I've been running into the same 
problem with both. After booting, if the computer sits for long enough 
(usually hours), the connection appears to degrade and eventually a lot 
of disconnected/connected messages start flooding the system logs like this:

May 17 13:21:50 video wifi0: LinkStatus=2 (Disconnected)
May 17 13:21:50 video wifi0: LinkStatus: BSSID=00:09:5b:3e:ee:26
May 17 13:21:50 video wifi0: Preferred AP BSSID 00:09:5b:3e:ee:26
May 17 13:21:50 video wifi0: using preferred AP selection
May 17 13:21:50 video wifi0: JoinRequest: BSSID=00:09:5b:3e:ee:26 channel=7
May 17 13:21:50 video wifi0: LinkStatus=2 (Disconnected)
May 17 13:21:50 video wifi0: LinkStatus: BSSID=44:44:44:44:44:44
May 17 13:21:50 video wifi0: LinkStatus=2 (Disconnected)
May 17 13:21:50 video wifi0: LinkStatus: BSSID=44:44:44:44:44:44
May 17 13:21:50 video wifi0: LinkStatus=2 (Disconnected)
May 17 13:21:50 video wifi0: LinkStatus: BSSID=44:44:44:44:44:44
May 17 13:21:50 video wlan0: Trying to join BSSID 00:09:5b:3e:ee:26
May 17 13:21:50 video wifi0: LinkStatus=1 (Connected)
May 17 13:21:50 video wifi0: LinkStatus: BSSID=00:09:5b:3e:ee:26

At this point, iwconfig reports the noise level as being around -97dBM 
(starts around -85dBM), Tx excessive retires to be greater than zero 
(but usually less than 10), and invalid misc to be in the thousands. 
Keep in mind that everything appears normal until a bit of time passes. 
Meaning there's no complains of disconnections or anything in the logs 
then there's a seemingly non-stop flow until the system is rebooted at 
which point everything returns to normal and SSH sessions become more 
responsive.

I'm also using wpa_supplicant to manage the connection, and the system 
is sitting right next to the WAP that it's connecting to. Any ideas on 
what might be wrong? I would like to leave this system in a remote 
location, but the excessive rebooting thing needs to be fixed first.

wifi0: NIC: id=0x8013 v1.0.0
wifi0: PRI: id=0x15 v1.1.1
wifi0: STA: id=0x1f v1.7.4

Thanks



More information about the HostAP mailing list