[PATCH] Allow compiling wpa_gui-qt4 for Qt 3.x

Jouni Malinen jkmaline at cc.hut.fi
Tue Mar 28 22:33:48 EST 2006


On Tue, Mar 28, 2006 at 10:25:19PM -0500, Pavel Roskin wrote:

> This patch allows to compile wpa_gui-qt4 for Qt 3.x.  Thus, the same
> source can be used for both Qt 3.x and Qt 4.x.  I think this patch could
> be applied, then files from wpa_gui-qt4 could be copied over wpa_gui,
> and then wpa_gui-qt4 could be removed.  I don't think wpa_gui will use
> any Qt4 features any time soon, so it's better to have a single source.

Interesting.. I had not consider this for two reasons: I was actually
planning on getting rid of Qt3 compat stuff completely and was expecting
this to require more changes.

Qt3 compat library increases size requirements for Qt4 GUIs quite a lot
and because of that it would really be nice to get rid of that..
However, this would also mean that your patch would not be of much use
since Qt3 would be unable to handle the end result easily.

In most cases, I would certainly prefer to have just one source code
tree, but this may require some more work to allow proper Qt4-only build
to work with the same tree. For now, I'll add this patch to a list of
things to consider and don't apply it before getting bit better
understanding on what really needs to happen with the Qt4 version of
wpa_gui. If nothing else, it might be worthwhile to move the current
wpa_gui-qt4 version and this patch into wpa_gui and continue working on
Qt4-only version on wpa_gui-qt4..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list