wpa_gui compilation

João Mamede foreveruni at clix.pt
Tue Mar 28 18:28:36 EST 2006


guys I'm trying to compile wpa_gui in my desktop everything compiles 
fine glibc version:2.3.6 gcc/g++ 4.0.3  qt 3.3.5
in my laptop I have glibc 2.3.6 gcc/g++ 4.0.3 qt(tried 3.3.5 and 3.3.6)
and I have this compilation error:
I've tried with make wpa_gui too in wpa_supplicant-0.4.7(tried 0.5.2 and 
0.5.1 versions too :( nothing)

root at SIV:/usr/src/wpa_supplicant-0.4.7/wpa_gui# make
g++ -c -pipe -Wall -W -O -march=pentium4 -mmmx -mfpmath=sse -msse -msse2 
-pipe  
-DQT_NO_DEBUG -DQT_SHARED -DQT_THREAD_SUPPORT 
-I/usr/share/qt/mkspecs/default -I
. -I.. -I/usr/include/qt -I.ui/ -I. -I.moc/ -o .obj/wpagui.o .ui/wpagui.cpp
.ui/../wpagui.ui.h: In member function 'void WpaGui::destroy()':
.ui/../wpagui.ui.h:80: error: 'free' was not declared in this scope
.ui/../wpagui.ui.h: In member function 'virtual void WpaGui::parse_argv()':
.ui/../wpagui.ui.h:92: error: 'getopt' was not declared in this scope
.ui/../wpagui.ui.h:97: error: 'free' was not declared in this scope
.ui/../wpagui.ui.h:98: error: 'optarg' was not declared in this scope
.ui/../wpagui.ui.h: In member function 'int 
WpaGui::openCtrlConnection(const cha
r*)':
.ui/../wpagui.ui.h:116: error: 'free' was not declared in this scope
.ui/../wpagui.ui.h:126: error: 'free' was not declared in this scope
.ui/../wpagui.ui.h:146: error: 'malloc' was not declared in this scope
.ui/../wpagui.ui.h:167: error: 'free' was not declared in this scope
.ui/../wpagui.ui.h:171: error: 'free' was not declared in this scope
.ui/../wpagui.ui.h: In member function 'virtual void 
WpaGui::processMsg(char*)':
.ui/../wpagui.ui.h:518: error: 'atoi' was not declared in this scope
make: *** [.obj/wpagui.o] Error 1

Hope you guys help me.
Tnx
Joao Mamede



More information about the HostAP mailing list