IEEE8021X problem

Alexey Marinichev hostap at lyosha.org
Sat Mar 25 22:37:13 EST 2006


Hello,

I've been trying to get wpa_supplicant to work with our wireless network 
at work for quite a while and I'm always seeing the same problem: 
"SSL_connect - want more data".  Here's the log:

EAPOL: Received EAP-Packet frame
EAPOL: SUPP_BE entering state REQUEST
EAPOL: getSuppRsp
EAP: EAP entering state RECEIVED
EAP: Received EAP-Request method=25 id=133
EAP: EAP entering state GET_METHOD
EAP: initialize selected EAP method (25, PEAP)
EAP-PEAP: Forced PEAP version 0
EAP-PEAP: Phase2 EAP types - hexdump(len=1): 1a
CTRL-EVENT-EAP-METHOD EAP method 25 (PEAP) selected
EAP: EAP entering state METHOD
SSL: Received packet(len=6) - Flags 0x21
EAP-PEAP: Start (server ver=1, own ver=0)
EAP-PEAP: Using PEAP version 0
SSL: (where=0x10 ret=0x1)
SSL: (where=0x1001 ret=0x1)
SSL: SSL_connect:before/connect initialization
SSL: (where=0x1001 ret=0x1)
SSL: SSL_connect:SSLv3 write client hello A
SSL: (where=0x1002 ret=0xffffffff)
SSL: SSL_connect:error in SSLv3 read server hello A
SSL: SSL_connect - want more data
SSL: 101 bytes pending from ssl_out
SSL: 101 bytes left to be sent out (of total 101 bytes)
EAP: method process -> ignore=FALSE methodState=MAY_CONT decision=FAIL
EAP: EAP entering state SEND_RESPONSE
EAP: EAP entering state IDLE

The network part from my config file looks like this:
network={
        ssid="ssid"
        key_mgmt=IEEE8021X
        eap=PEAP
        identity="name at company.com"
        password="password"
        phase1="peapver=0"
        phase2="auth=MSCHAPV2"

        priority=0
}

Any ideas what it is and what I should try?  Instructions for using 
wireless network from Windows explicitly state that "Validate server 
certificate" should be unchecked.

Thanks!

Lyosha



More information about the HostAP mailing list