Intersil Prism2/2.5 card crashing with hostap driver

bitbuck3t+hostap at gmail.com bitbuck3t+hostap at gmail.com
Wed Mar 1 16:58:12 EST 2006


This output was without the orinoco driver loading.  I can include the
output with the orinoco driver if needed.  When the orinoco driver loads,
everything works fine with the card.  The system also loads the hostap
drivers when Orinoco is loaded, but they don't seem to bind to the card at
all.

On 3/1/06, Jim Thompson <jim at netgate.com> wrote:
>
> bitbuck3t+hostap at gmail.com wrote:
>
> > I'm not quite sure where my problem lies, so I'll try to explain as
> > much as I can.  I have a Senao 2511CD Plus EXT2 card, which is an
> > Intersil Prism 2.5 card.  I am running Zenwalk 2.2 (slackware based
> > distro) with a 2.6.15.4 <http://2.6.15.4/> kernel.  When I plug the
> > card into my system, the orinoco and hostap drivers load, but the card
> > binds to the orinoco driver.  I have commented out the modalias
> > reference in modules.pcimap for the orinoco.  When I plug the card in
> > now, the hostap drivers attempt to load, however, things start going
> > very wrong at this point.  I am attaching the dmesg output when I plug
> > in the card with the hostap drivers and also when I attempt to eject
> > the card.  Once I eject the card, I get a traceback and I can no
> > longer plug anything into my pcmcia slot without rebooting.  I have
> > been searching for about a week and have tried finding information to
> > fix this, however, I have had no luck.  Any help would be greatly
> > appreciated.  This problem has entered an area of linux that I am just
> > not familiar with.  I have been reading up on udev and how that works
> > in case it is doing something screwy, but I am still no closer to
> > fixing the problem.  Thanks again for any help.
>
> Your problem started here:
>
> prism2_hw_init: initialized in 199 ms
> wifi0: NIC: id=0x800c v1.0.0
> wifi0: PRI: id=0x15 v1.1.0
> wifi0: STA: id=0x1f v1.4.9
> wifi0: defaulting to bogus WDS frame as a workaround for firmware bug in
> Host AP mode WDS
> wifi0: Command completion event, but no pending commands
> hostap_cs: assuming no Primary image in flash - card initialization not
> completed
> wifi0: test Genesis mode with HCR 0x1f
>
> for whatever reason, the firmware on your card is either very slow to
> respond, or fails to respond at all.
>
> Is the orinoco driver still loaded?
>
> Did the card work with the orinoco driver (in BSS or IBSS mode)?
>
> Jim
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20060301/004fc26f/attachment.htm 


More information about the HostAP mailing list