can't configure wpa

igor155 at free.fr igor155 at free.fr
Sun Jun 25 12:24:28 EDT 2006


> > I have an opensuse 10.1 with Madwifi-ng compiled by myself. wpa_supplicant
> > installed by rpm. So far, the wpn311 Netgear pci card (atheros based) is
> > working without encryption but I don't know how to use wpa_supplicant.
> > I use WPA2 PSK (AES) so I generated a conf file with wpa_passphrase with my
> > router passphrase, added proto=WPA2
>
> Where did you add the proto=WPA2?

in the conf file like this:
network={
        ssid="NETGEAR"
        #psk
        psk=my_secret_key_generated_by_wpa_passphrase
        key_mgmt=WPA-PSK
        proto=WPA2
}

> > proto: 0x1
>
> That line from the debug log seems to indicate that the configuration
> was done with proto=WPA, not WPA2..
>
> > 0: 00:0f:b5:ab:e9:22 ssid='NETGEAR' wpa_ie_len=0 rsn_ie_len=22 caps=0x11
> >    skip - no WPA/RSN proto match
>
> And since the AP is only using WPA2, wpa_supplicant refuses to select it
> with proto=WPA configuration.

I tried again with -dd and it seemed to work till I stopped the test and run in
background mode. Here are some parts:

wpa_driver_madwifi_set_key: alg=CCMP key_idx=2 set_tx=0 seq_len=6 key_len=16
WPA: Key negotiation completed with Mac:Address:Router:Here [PTK=CCMP GTK=CCMP]
Cancelling authentication timeout
Removed BSSID Mac:Address:Router:Here from blacklist
State: GROUP_HANDSHAKE -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to Mac:Address:Router:Here completed (auth)

Did I miss something?





More information about the HostAP mailing list